Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

?Unwanted deleting directories (fatal error)
Goto page 1, 2, 3  Next
 
Post new topic   Reply to topic    Total Commander Forum Index -> TC Fixed bugs Printable version
View previous topic :: View next topic  
Author Message
ThunderBoy
Junior Member
Junior Member


Joined: 12 Jul 2006
Posts: 16

PostPosted: Wed Oct 16, 2013 7:54 am    Post subject: ?Unwanted deleting directories (fatal error) Reply with quote

Already happened to me several times that this version of Total Commander clears the directories and files that do not want to delete all.
This problem have beta version 8.50 (I tested the version 3 and 5).

Figured out that the problem becomes as follows:
I have a folder "MEDIA", where i have two subfolders "CATALOG" and "TEMPLATE" them and some files folders outside. Open folder "CATALOG" and it selects all files through (Ctrl+A and Ctrl+X), which then via Ctrl+V to paste to the folder "TEMPLATE". Now i want to delete the directory "CATALOG", from which i moved all the files. Either my directory "CATALOG" for the first time does not erase or erase me completely whole "MEDIA", which is now located.

Before deleting i noticed in the confirmation window that appears when deleting the name correctly. I think the name of the directory that i want to delete. The program deletes everything very quickly, so i miss not respond and cancel the deletion! Once i have wanted to erase everything from the system folder C:

It does not happen always, but i have a head in sadness, because the deleted files and directories then have to painstakingly restore. Evil or Very Mad
Back to top
View user's profile Send private message
elgonzo
Member
Member


Joined: 04 Sep 2013
Posts: 135

PostPosted: Wed Oct 16, 2013 8:27 am    Post subject: Reply with quote

I could not reproduce your problem with TC8.50b5 32-bit and 64-bit on Windows 7 Pro x64.

Could you please provide some step-by-step instructions, perhaps? Especially about whether you do it all within one pane of TC, or whether you utilize both left and right panes (and how exactly).

Please also include information about on what kind of drive(s) you experienced the issue.
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 28269
Location: Switzerland

PostPosted: Wed Oct 16, 2013 9:03 am    Post subject: Reply with quote

1. Are these directories or virtual folders (e.g. on an external device)?
2. Which Windows version do you use?
3. Which delete method?
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ThunderBoy
Junior Member
Junior Member


Joined: 12 Jul 2006
Posts: 16

PostPosted: Wed Oct 16, 2013 9:40 am    Post subject: Reply with quote

I'm working on Windows 7 64bit SP1.

It is completely one, whether you are working with a virtual (USB) or physical directories (HDD).
This problem is probably only when you work with a Windows clipboard via keyboard shortcuts (Copy, Paste and Cut).
How the problem occurs, i have already written. If i only worked with the left window of the TC.
The right window, i did not. But i think i have done well in the right window of the TC.
Delete i used to just press the Delete key. When deleting empty directories do not use Shift+Delete. Otherwise i would have deleted the data never recovered.
Back to top
View user's profile Send private message
ThunderBoy
Junior Member
Junior Member


Joined: 12 Jul 2006
Posts: 16

PostPosted: Wed Oct 16, 2013 9:45 am    Post subject: Reply with quote

Yes, i use the TC 32bit 64bit on Windows, whereas most of the plugins for 64bit yet does not want to run. Maybe there will be a problem.
Back to top
View user's profile Send private message
elgonzo
Member
Member


Joined: 04 Sep 2013
Posts: 135

PostPosted: Wed Oct 16, 2013 12:58 pm    Post subject: Reply with quote

I still cannot reproduce.

@ThunderBoy, please verify my steps and correct me if you did something differently.

I use TC8.50b5 32-bit with a fresh wincmd.ini.
My operating system is Windows 7 Pro x64 SP1.
I execute all steps with the keyboard only, i never use the mouse.

    1. On my D:\ drive (internal HDD, NTFS-formatted), i create a MEDIA directory.
    Full path: "D:\MEDIA".

    2. Within the MEDIA directory, i create a directory CATALOG and a directory TEMPLATE.
    Full path names of the two directories: "D:\MEDIA\CATALOG" and "D:\MEDIA\TEMPLATE"

    3. I copy 10 random files into the "D:\MEDIA\CATALOG" directory.
    In my case, these files are PDF, TXT and DOC files.

    4. I have the directory "D:\MEDIA\CATALOG" open in the left pane, showing the 10 files.
    The right pane shows a different drive, in my case the root directory of drive F:. (The right pane will never be used.)

    5. With TC's cursor in the left pane, i press CTRL+A.
    All 10 files are being selected.

    6. Now i press CTRL+X. (No visible response).

    7. As the cursor is already on the entry "[..]", i just press ENTER.
    The left pane now shows the content of the "D:\MEDIA" directory.
    (The content shown is the CATALOG and the TEMPLATE directory.)

    8. I navigate with the cursor keys to the TEMPLATE directory and press ENTER.
    The left pane now shows the empty "D:\MEDIA\TEMPLATE" directory.

    9. I press CTRL+V. Within a very short time, the 10 files appear in the "D:\MEDIA\TEMPLATE" directory.

    10. As the cursor is already on the entry "[..]", i just press ENTER.
    The left pane now shows the content of the "D:\MEDIA" directory again.

    11. I navigate with the cursor keys to the CATALOG directory and press the DELETE key.

    12. TC asks me if i want to move the CATALOG directory into the recycle bin.
    I confirm with "Yes".

    Result: Only the empty CATALOG directory is being deleted. The TEMPLATE directory is still there, and it still contains all 10 files.
Back to top
View user's profile Send private message
ThunderBoy
Junior Member
Junior Member


Joined: 12 Jul 2006
Posts: 16

PostPosted: Thu Oct 17, 2013 5:36 am    Post subject: Reply with quote

I tested it and figured out that the procedure is not so important. Just do exactly what you wrote.

Here i made a video of how it actually looks.
Download video: http://goo.gl/1oaoit

In the introduction, i work only with the mouse. Files and Directories then i have been working only with a keyboard.
When i put files into the directory, then press Backspace to go back and i'm going to delete this directory.
It does not matter if i delete this directory or another. Always do the same.
Already there, nothing else to do, just delete the folder visible.
Back to top
View user's profile Send private message
elgonzo
Member
Member


Joined: 04 Sep 2013
Posts: 135

PostPosted: Thu Oct 17, 2013 6:38 am    Post subject: Reply with quote

Strange, even following your video i could not reproduce.

From what i see, the names of the files you used are made of english characters only. Is this correct?

Could you please post the following sections of your wincmd.ini:

- [Configuration]
- [Confirmation]
- [Shortcuts]
- [FileSystemPlugins]

Also, could you please try to reproduce the problem without your wincmd.ini (close all instances of TC, rename your existing wincmd.ini, start TC again)?
Back to top
View user's profile Send private message
ThunderBoy
Junior Member
Junior Member


Joined: 12 Jul 2006
Posts: 16

PostPosted: Thu Oct 17, 2013 7:07 am    Post subject: Reply with quote

This video is made on a completely new installation of Total Commander.
So the whole configuration is wincmd.ini base without any modifications.
Now i tested the version 8.50b6 and there is the same problem.
At first he does not want to delete the directory.
I'll try later at a friend's, or will have with the same problems.
Back to top
View user's profile Send private message
elgonzo
Member
Member


Joined: 04 Sep 2013
Posts: 135

PostPosted: Thu Oct 17, 2013 7:34 am    Post subject: Reply with quote

ThunderBoy wrote:
This video is made on a completely new installation of Total Commander.
So the whole configuration is wincmd.ini base without any modifications.
Now i tested the version 8.50b6 and there is the same problem.
At first he does not want to delete the directory.
I'll try later at a friend's, or will have with the same problems.


In your video, you obviously attempt to delete the "music" directory which contains the files.

TC asks you whether the directory should be deleted, and that's it...


However, in TC's default configuration, "Get confirmation before Deleting non-empty directories" is enabled (you find it in TC's configuration dialog, section "Misc.").
What should happen in your video with a fresh unmodified wincmd.ini, is that after asking whether "music" should be deleted another dialog should open, asking "The directory c:\dir\media\music is not empty. Do you want to delete it with all its files and subdirectories?"

But it doesn't happen in your case, which seems to indicate that you must have disabled this confirmation in the configuration dialog (which means that your wincmd.ini has been modified).
Could you please double-check this.
Back to top
View user's profile Send private message
MVV
Power Member
Power Member


Joined: 03 Aug 2008
Posts: 5820
Location: Russian Federation

PostPosted: Thu Oct 17, 2013 7:46 am    Post subject: Reply with quote

elgonzo,
There are two strange things:
1. No 'not empty dir' confirmation.
2. When he deletes media/music dir, TC (or someone else) deletes entire media dir (which is completely strange because you can't tell to TC to delete upper-level dir).
_________________
TCFS2 + TCFS2Tools: Full-screen mode for TC etc (forum)
TOTALCMD.NET: AskParam, CopyTree, NTLinks, Sudo, VirtualPanel…
Back to top
View user's profile Send private message Send e-mail
elgonzo
Member
Member


Joined: 04 Sep 2013
Posts: 135

PostPosted: Thu Oct 17, 2013 8:06 am    Post subject: Reply with quote

MVV wrote:

1. No 'not empty dir' confirmation.


I already asked ThunderBoy about this Smile

MVV wrote:

2. When he deletes media/music dir, TC (or someone else) deletes entire media dir (which is completely strange because you can't tell to TC to delete upper-level dir).


That is exactly the problem he has, which is not only strange, but has the demonstrated potential of causing data loss.
Right now we are still trying to figure out what TC configuration ThunderBoy had when reproducing the issue. I could not reproduce the problem, no matter what delete method, no matter whether confirmations are enabled/disabled, no matter whether using Windows or NC keyboard control scheme...
Back to top
View user's profile Send private message
ThunderBoy
Junior Member
Junior Member


Joined: 12 Jul 2006
Posts: 16

PostPosted: Thu Oct 17, 2013 8:43 am    Post subject: Reply with quote

So the fix. I tried it once on a completely new installation of TC.
I searched through the system disk to a file, from which the wincmd.ini was anywhere would be able to read the data of the TC.
I ran the program (8.50 b6), confirmed the initial window (button 1, 2, 3).
Then another window, where i just pressed OK. I am ready to look for directories to the test.
I have tested it at least 10 times as in the video. It worked perfectly.
I again closed and deleted all the files the wincmd.ini file, which i have on the system disk found.
Then i booted the TC with my configuration, which is on a different disk and tested all over again.
Now for the first time, those directories erased me like in the video.

So the error is likely to be somewhere in my configuration of TC (wincmd.ini).
I'm going to continue to test and when i get to it, which makes this entry a problem, so i will write it here.

My configurtion

[Configuration]
1hourdif=0
Aligned extension=1
AllHiddenNetNames=1
AltSearch=1
AlwaysCopyInBackground=1
AlwaysPackInBackground=2
AlwaysToRoot=0
AlwaysUnpackInBackground=2
Autotreechange=0
BreadcrumbDelayButton=-250
CdCloseDoor=0
CDlabel=1
ColorFilters=0
CompareCaseSensitive=0
CompareIgnoreRepeatedLines=1
CompareIgnoreRepSpace=1
Comparetool=Y:\Programs\PSPad editor\PSPad.exe
CompareVertical=0
CopyComments=30
CopyDirTimeStamp=1
CopyHugeBlockSize=10240
CopyHugeBlockSizeOther=64
CopyStreams=1
CountMarked=1
CountSpace=1
CustomFieldsInDlg=0
DirBrackets=0
DirTabLimit=32
DirTabOptions=1001
DriveLib=%COMMANDER_PATH%\Icons\drivebmp.dll
DriveTipDelay=0
Editor=""Y:\Programs\PSPad editor\PSPad.exe" "%1""
EditWaitTime=2
ExplorerForCopy=0
FileTipWindows=1
firstmnu=1349
FirstTime=0
FirstTimeUnpack=0
FirstTimeZIP=0
CheckUsbHdd=0
IcnsSpecialFolders=3
IconClickSelection=1
IconLib=%COMMANDER_PATH%\Icons\
IconOverlays=1
IconsInMenus=19
IconsOnNet=1
IconsSpecialFolders=3
IgnoreListFile=%COMMANDER_PATH%\Config\Ignore_list.txt
IgnoreListFileEnabled=1
InstallDir=Y:\Programs\Total Commander\
KeyPath=Y:\Programs\Total Commander\Config\
LanguageIni=wcmd_sk.lng
Lastmd5=2
LastRunAs=Administrator
LastSearchOptions=40
Listname=%COMMANDER_PATH%\ftplist.txt
LockedTabChange=1
LogKeepCount=30
LogOptions=7198
LogRotateLimit=0
LongInStatus=0
Mainmenu=wcmd_sk.mnu
MarkDirectories=1
NewStyleProgress=1
OldDriveIcons=0
OldStyleTree=1
Onlyonce=0
PanelsVertical=0
Pluginbasedir=%COMMANDER_PATH%\plugins
PreloadThumbnails=0
QuickSearchAutoFilter=1
QuickSearchExactMatch=0
QuickSearchMatchBeginning=1
RenameSelOnlyName=1
ResolutionSpecific=1
SaveCommands=1
SaveHistory=0
Savepanels=0
Savepath=1
SeparateTree=0
SetArchiveBitOnRename=1
ShellExtIcons=1
ShowCentury=1
ShowCopyOptions=1
ShowEXEandLNKicons=1
ShowHiddenSystem=1
Showicons=2
ShowParentDirInRoot=0
SingleClickStart=0
SizeFooter=1
SizeCheck=1
SizeStyle=0
Small83Names=0
SortDirsByName=0
SortUpper=3
SoundDelay=20
SpaceMovesDown=1
SpeedLimit=23
StartupScreen=1
SyncButtons=50
SyncFlags=7
TabEnterDirChange=1
Test=135
ThumbExplTypes=*.* | *.htm *.html
ThumbHeightNoCache=128
ThumbIrfXnTypes=*.*
ThumbnailMemoryLimit=500
ThumbnailPrealloc=100000
ThumbOptions=15
ThumbPlgTypes=*.*
ThumbsCopyDel=1
ThumbsCustomFieldsEnabled=1
ThumbsInDlg=0
ThumbsLocation=
ThumbTxtTypes=*.txt *.ini
ThumbWidthNoCache=128
Tips=3
ToolTipDelay=300
TrayIcon=0
TreeFileLocation=%SystemRoot%\TEMP
ttciniwritable=13650
UnicodeListWarn=1
UseFindForTime=1
UseLongNames=1
UseNewDefFont=0
UseRightButton=1
UseTrash=1
VersionInOverwrite=1
Viewer=none
Viewertype=0
WantXPLook=1
WatchDirs=59
Win32TipWindows=1
Win95Delete=0
WmfAllowed=3
XPMoveMethod=1
ZipMagic=0

[Confirmation]
deleteDirs=1
OverwriteFiles=1
OverwriteReadonly=1
OverwriteHidSys=0
MouseActions=0

[Shortcuts]

[FileSystemPlugins]
Skartovač=%COMMANDER_PATH%\Plugins\WFX\Wipe\wipe.wfx
FTP servery=%COMMANDER_PATH%\Plugins\WFX\FTPList\FTPList.wfx
Špeciálny odinštalátor=%COMMANDER_PATH%\Plugins\WFX\UnInstTC\UnInstTC.wfx
Položky pri štarte windows=%COMMANDER_PATH%\Plugins\WFX\StartupGuard\StartupGuard.wfx
Služby windows=%COMMANDER_PATH%\Plugins\WFX\Services\services.wfx
Register=%COMMANDER_PATH%\Plugins\WFX\Registry\Registry.wfx
Skladisko hesiel=%COMMANDER_PATH%\Plugins\WFX\PassStore\PassStore.wfx
HTTP prehliadač=%COMMANDER_PATH%\Plugins\WFX\Httpbrowser\httpbrowser.wfx
Udalosti systému=%COMMANDER_PATH%\Plugins\WFX\EventNT\EventNT.wfx
Správca zariadení=%COMMANDER_PATH%\plugins\WFX\Device Manager\devman.wfx
Clipboard=%COMMANDER_PATH%\plugins\WFX\DecClipboardFS\decClipboardFS.wfx
Kalendár=%COMMANDER_PATH%\Plugins\WFX\Calendar\calendar.wfx
Vymazané súbory=%COMMANDER_PATH%\plugins\wfx\Back2Life\Back2Life.wfx
AceHelper=%COMMANDER_PATH%\Plugins\WFX\AceHelper\AceHelper.wfx
Ultra odinštalátor 64=%COMMANDER_PATH%\plugins\WFX\Uninstaller64\Uninstaller64.wfx
Disk Internals Reader=%COMMANDER_PATH%\plugins\WFX\DiskInternals_Reader\DiskInternals_Reader.wfx
Premenné prostredie=%COMMANDER_PATH%\plugins\WFX\Environment Variables Ex\envvars.wfx
PCIDetect=%COMMANDER_PATH%\plugins\WFX\PCIDetect\wfx_pcidetect.wfx
Back to top
View user's profile Send private message
elgonzo
Member
Member


Joined: 04 Sep 2013
Posts: 135

PostPosted: Thu Oct 17, 2013 8:54 am    Post subject: Reply with quote

@ThunderBoy,
i did a quick test with your INI, but not with your file system plug-ins. But i still could not reproduce.

My (totally speculative) guess is that one of the file system plug-ins might be the culprit. decClipboardFS sticks out, because it has something to do with the clipboard (but i am not sure and frankly not really convinced that it really causes the problem, though). If FS plug-ins turn out to be harmless, also check the content and lister plug-ins you have installed...
Back to top
View user's profile Send private message
elgonzo
Member
Member


Joined: 04 Sep 2013
Posts: 135

PostPosted: Thu Oct 17, 2013 9:12 am    Post subject: Reply with quote

I see you have set "IgnoreListFile=%COMMANDER_PATH%\Config\Ignore_list.txt".

Could you perhaps try without Ignore_list.txt (but do not delete the file)?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC Fixed bugs All times are GMT - 6 Hours
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Impressum: This site is maintained by Ghisler Software GmbH

Using phpBB © 2001-2005 phpBB Group