[9.50] Lister Multimedia config: improper checkbox label

Bug reports will be moved here when the described bug has been fixed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
Flint
Power Member
Power Member
Posts: 3308
Joined: 2003-10-27, 09:25 UTC
Location: Moscow, Russia
Contact:

[9.50] Lister Multimedia config: improper checkbox label

Post by *Flint »

1. Set TC to use any language, except built-in English.
2. Set increased DPI setting in TC Font settings.
3. Open Lister - Configure - Multimedia.
4. Notice the label at the bottom checkbox (mostly covered by the "Define view method" button).

Basically, when translating, TC assigns to this checkbox the same label as for the top checkbox on this page ("Use plugins…"). You also can see that without increasing the DPI if you use some Window sniffer tool (e.g Spy++) which shows the control titles.

Screenshot

Tested in 9.50b4 32/64-bit. With built-in English it's not reproduced, only with translations.

<Added>
Some users reported that even in built-in English they have some text there, and it's not always the copy of the first checkbox'es title.
Last edited by Flint on 2019-11-10, 22:48 UTC, edited 1 time in total.
Flint's Homepage: Full TC Russification Package, VirtualDisk, NTFS Links, NoClose Replacer, and other stuff!
 
Using TC 9.51 / Win7 x64 SP1, Win10 x64

User avatar
Usher
Power Member
Power Member
Posts: 856
Joined: 2011-03-11, 10:11 UTC

Re: [9.50] Lister Multimedia config: improper checkbox label

Post by *Usher »

This is another dialog window (you have also reported System Info) which should be made larger. Currently some translated strings must be shortened and some font names are too long to fit in the button size.
Regards from Poland
Andrzej P. Wozniak

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39728
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: [9.50] Lister Multimedia config: improper checkbox label

Post by *ghisler(Author) »

There shouldn't be any text there at all, the text is on the button. I will fix it.
Author of Total Commander
http://www.ghisler.com

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39728
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: [9.50] Lister Multimedia config: improper checkbox label

Post by *ghisler(Author) »

This was fixed a while ago (label removed from checkbox), can someone check it with the latest beta please?
Author of Total Commander
http://www.ghisler.com

User avatar
Flint
Power Member
Power Member
Posts: 3308
Joined: 2003-10-27, 09:25 UTC
Location: Moscow, Russia
Contact:

Re: [9.50] Lister Multimedia config: improper checkbox label

Post by *Flint »

Seems fixed in b6 x64, but still present in b6 x32.
Flint's Homepage: Full TC Russification Package, VirtualDisk, NTFS Links, NoClose Replacer, and other stuff!
 
Using TC 9.51 / Win7 x64 SP1, Win10 x64

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39728
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: [9.50] Lister Multimedia config: improper checkbox label

Post by *ghisler(Author) »

You are right! Please check beta 7.
Author of Total Commander
http://www.ghisler.com

User avatar
Flint
Power Member
Power Member
Posts: 3308
Joined: 2003-10-27, 09:25 UTC
Location: Moscow, Russia
Contact:

Re: [9.50] Lister Multimedia config: improper checkbox label

Post by *Flint »

Confirm fixed in 9.50β7.
Flint's Homepage: Full TC Russification Package, VirtualDisk, NTFS Links, NoClose Replacer, and other stuff!
 
Using TC 9.51 / Win7 x64 SP1, Win10 x64

Post Reply