Dark Mode: Updir ([..]) item unthemed on reuse of cm_SwitchDarkmode after using Quick Searh filter with empty results

Bug reports will be moved here when the described bug has been fixed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
DrShark
Power Member
Power Member
Posts: 1569
Joined: 2006-11-03, 22:26 UTC
Location: Kyiv, 68/262

Dark Mode: Updir ([..]) item unthemed on reuse of cm_SwitchDarkmode after using Quick Searh filter with empty results

Post by *DrShark »

To reproduce:
1. Open wincmd.ini, change [Configuration] section by adding QuickSearchAllowNoMatch=1 to allow to enter/paste text in Quick Search which leads to empty results:

Code: Select all

[Configuration]
QuickSearchAllowNoMatch=1
Save wincmd.ini, close it.
2. Start TC, if it's not in dark mode - switch to it with cm_SwitchDarkmode command.
3. Activate Quick Search window with Ctrl+S, if filter mode for Quick Search is not active - press Ctrl+S again to activate it.
4. In Quick Search input field enter some name that doesn't exist, or even part of it doesn't exist in files names of panel filelist. The file list should become empty, focus (file cursor) should go to updir ([..]) item. You can also do the same in opposite panel.
5. Turn the dark mode off with cm_SwitchDarkmode, then turn it on again with the same command:
updir items in both panels will lose dark theme color (in my case they become white)

It's also possible to reproduce this if to start TC with dark mode off in step 2, and then just to activate it in step 5.

Reproduced in TC 9.50 beta 5 on Vista 32-bit with classic theme.
Android 4.3.1 no root, kernel 08.09.2016; Vista Home Premium SP2 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39728
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Dark Mode: Updir ([..]) item unthemed on reuse of cm_SwitchDarkmode after using Quick Searh filter with empty result

Post by *ghisler(Author) »

It's probably the same cause as this bug:
viewtopic.php?f=32&t=54603
Author of Total Commander
http://www.ghisler.com

sergiokapone
Junior Member
Junior Member
Posts: 10
Joined: 2017-01-17, 07:45 UTC

Re: Dark Mode: Updir ([..]) item unthemed on reuse of cm_SwitchDarkmode after using Quick Searh filter with empty result

Post by *sergiokapone »

I also found the same bug.
Russian Language of Total Commander
Win10 (1803)

User avatar
DrShark
Power Member
Power Member
Posts: 1569
Joined: 2006-11-03, 22:26 UTC
Location: Kyiv, 68/262

Re: Dark Mode: Updir ([..]) item unthemed on reuse of cm_SwitchDarkmode after using Quick Searh filter with empty result

Post by *DrShark »

history950.txt wrote:15.11.19 Fixed: Dark mode: Starting with fresh wincmd.ini set to dark mode and empty startup directories -> line with updir item wasn't drawn (32/64)
It seems this fix also fixed the problem described in this thread, checked in TC 9.50 beta 6 on Vista 32-bit with classic theme.
Android 4.3.1 no root, kernel 08.09.2016; Vista Home Premium SP2 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right

Post Reply