HistoryLenStored problem

Bug reports will be moved here when the described bug has been fixed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
tvholic
New Member
New Member
Posts: 1
Joined: 2012-08-15, 03:02 UTC

HistoryLenStored problem

Post by *tvholic »

With "HistoryLenStored=100" set, and 100 history entries already present in the [RightHistory] and [LeftHistory] sections, TC stops saving new history entries to the INI file. Within the program I change to several different directories, and they get added to the bottom of the Alt-Down history list. But when I close and reopen the program they are gone, and the INI section didn't get updated. I have tried setting "HistoryThinning=0" and "HistoryCut=1" to make sure those aren't the issue.
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39969
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: HistoryLenStored problem

Post by *ghisler(Author) »

Confirmed, thanks. Please do not use HistoryLenStored for now, it stores the wrong part of the history. I will fix it in 9.50a.
Author of Total Commander
http://www.ghisler.com
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39969
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: HistoryLenStored problem

Post by *ghisler(Author) »

This should be fixed in 9.50a RC1, please test!
Author of Total Commander
http://www.ghisler.com
StatusQuo
Power Member
Power Member
Posts: 1524
Joined: 2007-01-17, 21:36 UTC
Location: Germany

Re: HistoryLenStored problem

Post by *StatusQuo »

I can confirm (since TC 9.50a RC1): [LeftHistory] and [RightHistory] are updated again (with HistoryLenStored=25; when closing TC or using cm_ConfigSaveDirHistory).
Who the hell is General Failure, and why is he reading my disk?
-- TC starter menu: Fast yet descriptive command access!
Post Reply