Don't work "UseNewDefFont=1" in Windows XP

The behaviour described in the bug report is either by design, or would be far too complex/time-consuming to be changed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
PiotrMP006
Junior Member
Junior Member
Posts: 10
Joined: 2014-03-05, 09:15 UTC

Don't work "UseNewDefFont=1" in Windows XP

Post by *PiotrMP006 » 2017-10-28, 13:57 UTC

Don't work "UseNewDefFont=1" in Windows XP.

I have installed the Segoe UI Regular fonts.

SEGOEUI.TTF
SEGOEUIB.TTF
SEGOEUII.TTF


TC can't find font if UseNewDefFont=1 ?


Please correct it in TC 9.11

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38451
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-10-30, 11:29 UTC

This is intentional. UseNewDefFont is ignored on Windows versions before Vista.
Author of Total Commander
http://www.ghisler.com

PiotrMP006
Junior Member
Junior Member
Posts: 10
Joined: 2014-03-05, 09:15 UTC

Post by *PiotrMP006 » 2017-11-03, 17:46 UTC

ghisler(Author) wrote:This is intentional. UseNewDefFont is ignored on Windows versions before Vista.
I wants to know the settings in wincmd.ini to use under Win XP with installed Segoe fonts in order to get the same look as a newly installed TC with UseNewDefFont=1 on any new Windows version.

Please help me

User avatar
petermad
Power Member
Power Member
Posts: 8994
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad » 2017-11-03, 17:49 UTC

2PiotrMP006
Please help me
I have already given you the answer here: http://ghisler.ch/board/viewtopic.php?p=334123#334123

Anyway - this is not a bug and the thread should be moved.
License #524 (1994)
Danish Total Commander Translator
TC 9.5b8 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38451
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2017-11-05, 10:22 UTC

The idea is that you can set UseNewDefFont=1 in an ini file which is shared between multiple Windows installations, and TC ignores it on systems which don't have the new fonts by default.
Author of Total Commander
http://www.ghisler.com

Post Reply