Page 3 of 6

TC Windows + TC Android + WiFi Plugin

Posted: 2017-06-12, 03:05 UTC
by Impeeza
Hi, I don't know if this is the correct place,

If I want to connect from TC Android using WiFi Transfer on Home Screen, to connect to a PC, there is any way to achieve this using Total Commander for Windows? or is needed a WEB Dav Server on Windows?


Posted: 2017-06-12, 13:30 UTC
by ghisler(Author)
You can use the "LAN" plugin to access Windows shared folders from your phone. Make sure to have a password for your Windows account.

Posted: 2017-08-25, 09:29 UTC
by DrShark
1. This name of the plugin is WiFi/WLAN. Does it mean it always uses a LAN device-device connection, even if sender device is already connected to Internet via Wi-Fi?

2. My Android language is Ukrainian, but I set English as a language of TC4A. WiFi/WLAN Plugin uses Ukrainian language in most parts of its interface. Please consider to make the plugin follow TC4A language setting.

3. Plugin webpage still refers to 2.01 version of apk (current plugin version is 2.02). Please update it.

4. Also please consider to remove the license restriction (the same existed earlier in TC4A) currently menitoned in plugin properties window (called by context menu on the plugin in TC4A root folder.)

Posted: 2017-08-28, 10:41 UTC
by ghisler(Author)
1. It uses only WiFi/WLAN connections, not connections via phone, because the transfer is unencrypted.

2. WiFi/WLAN uses same language as TC when opened from TC as receiver. But it uses the system language when launched to send files, because it can be launched from ANY app and can't see the language set in TC.

3. I will check it.

4. I will consider it.

Posted: 2017-08-30, 23:54 UTC
by DrShark
1. On unencrypted network it's possible to send private files in encrypted archive. Ability to send files using internet connection would allow to send files to reciever devices without Wi-Fi.

2. Please consider then to add a setting to a plugin to allow user to set own prefered language. The setting could be stored in some text file available for editing using 3rd party applications.

Posted: 2017-09-06, 10:05 UTC
by maxne123
Can You Please Provide Total Commander for IOS Devices also?

Posted: 2017-09-07, 09:15 UTC
by ghisler(Author)
Unfortunately Apps on iOS devices can only access their own data, there is no global file system as on Android. Therefore a file manager would be quite useless on iOS.

Posted: 2017-11-17, 00:10 UTC
by felix_inc
I hope my issue is not too remote to this topic.

First of all: Thanks for the awesome WiFi transfer plugin! I love it and use it a lot to transfer files from and to my mobile.
I would like to have something similar at my mac.

I know about AirDrop, SMB etc. but I am looking for a cross-system, no-client-software, no-account, HTTP-ish thing like this.
What I found is an app called SimpleHTTPServer. It does half the job. It makes a folder available via HTTP but as far as I've seen, it does not allow uploads to that folder.

So I appreciate any hint. Maybe the WiFi plugin was inspired by some other tool? Thanks for your help

Posted: 2017-11-17, 14:54 UTC
by ghisler(Author)
My WiFi plugin does exactly that! It creates a HTTP server. It does support uploads too when you share directories, and check the option to allow uploads on the plugin page (the one with the QR code). You can use any Web browser or a WebDAV client for uploads.

My fault... how to solve ?

Posted: 2017-11-30, 07:52 UTC
by mix
I've installed the plugin this morning to move some data from an older android device to a new one...
I've made a great mistake trying to shut down the server and letting it run again: I've removed the link to ///wifitransfer which appears on the main menu and I cannot make it appears again...
Tried uninstalling the plugin, reinstalling it, searching for a configuration file around (not so fond of such things...).

How might I solve this ?

Unfortunately I did this on the newer device (was it on the older it wasn't a problem as I will have to factory reset it...).

Thank you for the suggestion/help/hint...

BTW: I've used it two minutes and it perfectly did what I needed, so I'll definitely keep and 5 star rate it ... ;-)

Posted: 2017-12-01, 15:16 UTC
by ghisler(Author)
You can long tap on the first or last item in the list and choose "Show all hidden" to view it again.

Posted: 2017-12-11, 15:13 UTC
by GeroZ
ghisler(Author) wrote:My WiFi plugin does exactly that! It creates a HTTP server. It does support uploads too when you share directories, and check the option to allow uploads on the plugin page (the one with the QR code). You can use any Web browser or a WebDAV client for uploads.
I was hoping for exactly that, but I might be too stupid to get this to work. ;-)

First of all: Yes, I can manually type the WiFi plugin's URL into my PC/Mac's web browser (e.g. Chrome), and I see the file listing – plus the option to upload a single file via HTTP upload (if configured). So I'm versed enough to get both the phone = server and the computer = client into the same (W)LAN.

However: I can not connect to my phone via regular WebDAV. On a Mac, I simply hit Cmd-K ("Connect to Server") and enter the http URL – but it always gives me an error message.

However-however: I'm also savvy enough to make WebDAV work – with other WebDAV servers, like the usual suspects (WebDAV server or WebDAV Server Ultimate). … Both lack the ability to write to the external SD card, so I'd very much like to use TCMD as my WebDAV server.


So it is my suspicion that TCMD's WiFi plugin's web server does not implement WebDAV the way it should.

For the sake of completeness: I have the Windows version of Total Commander ready, including the WebDAV plugin. Both are running under WINE on a Mac, which indeed doesn't matter: I am able to connect from TCMD/Win/WINE to above mentioned WebDAV server on my Android phone just fine.


So – what am I doing wrong? Why doesn't TCMD/Android's WiFi plugin behave like a regular WebDAV server? Or do I need to activate it somewhere?

UPDATE: Same from native Windows 10 – WebDAV server works just fine as a WebDAV server, TCMD/Android/Wifi Plugin does not.

Posted: 2017-12-14, 10:24 UTC
by ghisler(Author)
You cannot use the Windows 10 client, it only supports https, not http. However, https isn't possible because the phone doesn't have a fixed name for which you could buy a certificate. Https isn't really needed because the connection remains within your (encrypted) WiFi network and doesn't go through the Internet.

You can use Total Commander for Windows with my WebDAV plugin, though.

Regarding the mac, can you post a log of the failed connection? My WiFi plugin does implement a complete WebDAV server, but your client may also be https only.

Posted: 2017-12-15, 14:39 UTC
by GeroZ
Well, umm …

My German MacOS just states that there was an error and that I should contact my sysadmin (which, who would have thought, I am) for more information.

I installed "cadaver", a command line WebDAV client (usually native to Linux, now via Homebrew for macOS). It connects to the other mentioned Android WebDAV connects without any problems.

Code: Select all

gero-new-mbp:~ gerozahn$ cadaver
dav:/> ls
Listing collection `/': succeeded.
Coll:   Android                                0  Nov 11 10:29
Coll:   LOST.DIR                               0  Okt 30 15:56
Coll:   MP3                                    0  Nov 10 10:03
Connection to `' closed.
gero-new-mbp:~ gerozahn$ 
But when trying to connect to the TCMD Wi-Fi plugin, it merely yields "501 Not Implemented". … As I said: Android server and (Mac) client are on the same network, otherwise the other WebDAV server could not be reached either. … And no: It doesn't help to activate/deactivate only one of them at a time.

Code: Select all

gero-new-mbp:~ gerozahn$ cadaver
Could not open collection:
501 Not Implemented
gero-new-mbp:~ gerozahn$ 
When I open the respective URL with my browser, I get a full listing from the other WebDAV server, but only a "403 Forbidden" from the TCMD server.

I know that the TCMD URL also contains a suffix, which enables me to open the web view. But adding this does not change anything when trying to open the WebDAV connection.


Can you name a WebDAV client (Win/Mac/Linux) that I could try, which is proven to work?

Posted: 2017-12-15, 15:30 UTC
by GeroZ
ghisler(Author) wrote:You cannot use the Windows 10 client, it only supports https, not http.
You're mistaken. As I am typing this, I am using Windows 10/1709, and I have opened an http WebDAV address (not https) on my Android phone with above mentioned "WebDAV Server".


I now tried CarrotDAV on Windows 10/1709. As expected, above mentioned "WebDAV Server" for Android can be reached just fine. However, trying to connect to TCMD reports error 501 when clicking the "Test" button – with or without the path suffix:

Code: Select all

Der Remoteserver hat einen Fehler zurückgegeben: (501) Nicht implementiert.
   bei Rei.Fs.Webdav.WebdavFs.GetResponse(HttpWebRequest request, Boolean notreqstream)
   bei Rei.Fs.Webdav.WebdavFs.GetResourceOptions(Uri target)
   bei Rei.Fs.Webdav.ConnectionTestForm.Check()[quote][/quote]