Page 2 of 5

Posted: 2014-09-26, 16:17 UTC
by Hinz
ghisler(Author) wrote:actually the best solution is Towelroot with SDFix. If your firmware is too new, downgrade to 4.4.2 and use Towelroot.
My version is 4.4.2, but the kernel is from June 24. So I think it wouldn't work, because it's not from June 3 or older :(


Posted: 2014-09-26, 18:18 UTC
by franc
This CAT B15Q is with kernel from may but towelroot with modstrings didn't work at least with:

1337 0 1 0 4 0
1337 1 1 0 4 0
1337 2 1 0 4 0
1337 3 1 0 4 0
1337 0 0 0 4 0
1337 1 0 0 4 0
1337 2 0 0 4 0
1337 3 0 0 4 0

When align (second Parameter) was 1 the phone rebooted after tapping the CmdButton, but no root after, like it is described in the towelroot app.
With align=0 nothing happens.
I tried more in this tread on xda

Posted: 2014-09-27, 12:37 UTC
by franc
Also das hat doch keinen Zweck!

I stop this now with the modstrings, this is just a very unuseful way to spend the weekend.
There are millions of possibilities and absolutely NO GUARANTEE that it could really root the phone, much more likely it is, that it won't work.
Each try takes half a minute as the phone reboots often in the vainly attempt.
Till I tried all possibilities in my spare time, the B15Q won't exist anymore ;)

No, no, no.
No root for with this towelroot for the CAT B15Q, no way with modstrings Mr. Ghisler :(

Posted: 2014-10-08, 18:28 UTC
by Pagefox
Leider bin ich auch von diesem Mist befallen.
Da mein Englisch nicht so gut ist, wäre es schön, wenn mir jemand Erklären könnte, was ich tun muß damit ich wieder auf meine SD-Karte schreiben kann.
Mein Smartphone [Samsung S4 von Vodafon] ist nicht gerootet


Posted: 2014-10-09, 10:27 UTC
by ghisler(Author)
Sie können entweder:
1. Den Dateimanager von Samsung benutzen: "Eigene Dateien". Nur vorinstallierte apps dürfen überall schreiben
2. TC 2.05 beta verwenden, der darf in sein privates Verzeichnis auf der Karte schreiben, sonst nirgends. OK für Backups, sonst unbrauchbar.
3. Das Gerät (temporär) rooten, dann mit dem tool sdfix aus dem Play Store die Karte zum Schreiben freigeben.

Posted: 2014-10-09, 14:21 UTC
by Pagefox
Danke für die Info

Re: How to get back write access to SD-Card on Android 4.4

Posted: 2014-10-12, 20:05 UTC
by Riccardo
Hallo Forum,

reicht es auch, wenn man ein CF-Auto-Root durchführt und anschließend das SDFix laufen lässt.

Details hier:

Möchte hier ein Samsung Tab 3 (GT-P5210) mit 4.4.2 rooten.

Thx, Richard

Posted: 2014-10-13, 10:13 UTC
by ghisler(Author)
Ja, jede beliebige Art zu Rooten ist OK. SDFix benötigt einfach Rootrechte, um die Berechtigungsdatei anpassen zu können. Danach wird Root nicht mehr benötigt.

Writing to SD on Root mode

Posted: 2014-10-14, 13:52 UTC
by Impeeza
Hi, recently i have to recover some of my NVRAM and get a wall trying to read/write to SD Card. i followed the steps on this post:

Specially the part about mounting the SD as a read-Write device:

Code: Select all

mount -t vfat /dev/block/vold/179:97 /mnt/media_rw/sdcard0
cd /data/nvram/APCFG/APRDEB
cp /mnt/media_rw/sdcard0/WIFI .
cp /mnt/media_rw/sdcard0/WIFI_CUSTOM .

seems android 4.4.X need to mount the SD in other link in write mode, because the default location is READ-ONLY.

hope this help.


Posted: 2014-11-09, 01:43 UTC
by Bartusg
Found an article that ao lists kernel versions that should be imune for Towelroot:

I was planning to buy an LG L90 that ships with kernel version 3.4.0+ -If I can read that as 3.4.0 I should be able to use Towelroot and SDFix.

My question is: Would SDFix still stick after an update? I probably would have to root it another way if ever I needed to install the fix again. Is it possible to keep updates off without using root? (during the first year I'd like to be as little rooted as possible)

Posted: 2014-11-25, 15:13 UTC
by nortoncommander
Can someone explain me, why tcmd 2.04 can write to internal card and not to external, even tcmd does not own the folder ?

I copied the whole whatsapp folder from old sony device to my computer and back to new device samsung s3 neo. Everything fine.

Btw the whatsapp folder existed on new device because I installed it previously. I had to uninstall before copying. I thought uninstalling deletes all folders from the device.

best regards

Posted: 2014-11-26, 10:53 UTC
by franc
nortoncommander wrote:Can someone explain me, why tcmd 2.04 can write to internal card and not to external, even tcmd does not own the folder ?...
Please read this:!msg/android-platform/14VUiIgwUjY/UsxMYwu02z0J
and this:
and also this:

File Commander from mobisystems can write ext. SD-Card

Posted: 2014-11-26, 17:22 UTC
by juhanjuku
The beta version DOES support the new API to write to its own private SD-Card directory. When you go to the TC home folder, you can see multiple SD-Card links. The one with R/W in the name is the pointer to the private directory where TC is allowed to write.

Unfortunately there is no API to write anywhere on the external SD-Card.[/quote]

I have on my Sony Xperia Z1 (android 4.4.4) installed File Commander from Mobisystems and this app can write anywhere on external SD-Card.
So it must be possible also for TC or what?

Posted: 2014-11-27, 10:26 UTC
by ghisler(Author)
File Commander is a (pre-installed) Sony default app on the Z1. Only apps preinstalled by the manufacturer or made by Google are allowed to write everywhere on the external SD card. Apps installed by the user are not allowed to do this.

Posted: 2014-11-27, 15:46 UTC
by juhanjuku
Ok, lets' wait Android 5 then. Hopefully write to SD is free again in there.