'Samsungs private mode' sometimes failed on me

Support for Android version of Total Commander

Moderators: sheep, Hacker, Stefan2, white

Post Reply
Scoulder
Junior Member
Junior Member
Posts: 21
Joined: 2013-09-27, 07:51 UTC
Location: Germany

'Samsungs private mode' sometimes failed on me

Post by *Scoulder » 2018-06-19, 12:02 UTC

I am using a Samsung Galaxy S7 with Android Oreo.

Samsung has a "private mode" that gives access to a hidden partition after providing a password, a PIN or a gesture.
In Total Commander this mode shows as an additional drive:
• Interner Speicher (/storage/emulated/0)
• SD-Karte (/storage/<identifier>)
• privatemode (///_privatemode)

I am using this mode with Total Commander since Android 7 and now with Android 8.
In Android 7 this sometimes worked, sometimes not. I found that it sometimes failed when TC is already opened when I mount this private partition. Then TC gave me a message like "Do you want to give TC access to privatemode, including photo and video?" with "Deny" and "Allow". Klicking "Allow" gives me the same popup again and again. Checking "Don't ask anymore" leads to a greyed out "Allow"-button (Deny keeps being available).

Since using Android 8 this happens every time, so I can't get access to the privatemode with Total Commander anymore, I always have to use the Android file manager.

Any ideas how to regain access with TC in Android 8?

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37734
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-06-19, 14:41 UTC

Try killing TC via task manager and re-starting it. Closing via TC menu isn't sufficient.
Author of Total Commander
http://www.ghisler.com

Scoulder
Junior Member
Junior Member
Posts: 21
Joined: 2013-09-27, 07:51 UTC
Location: Germany

Post by *Scoulder » 2018-06-19, 14:49 UTC

No luck with that.
I stopped TC and after restarting it, I got the same error messages.
Same thing after a complete phone reboot.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37734
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-06-19, 15:00 UTC

It may not be possible to access it then. Have you tried with other (not preinstalled) file managers?
Author of Total Commander
http://www.ghisler.com

Scoulder
Junior Member
Junior Member
Posts: 21
Joined: 2013-09-27, 07:51 UTC
Location: Germany

Post by *Scoulder » 2018-06-19, 15:20 UTC

I just tested "Solid Explorer" which has no problem accessing the private partition. But I still like Total Commander more.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37734
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-06-20, 18:21 UTC

In this case there is hope that I can get it to work too. First, please try the latest beta from the play store, I made some changes there for Android 8:
https://play.google.com/apps/testing/com.ghisler.android.TotalCommander
Author of Total Commander
http://www.ghisler.com

Scoulder
Junior Member
Junior Member
Posts: 21
Joined: 2013-09-27, 07:51 UTC
Location: Germany

Post by *Scoulder » 2018-06-21, 07:05 UTC

Thanks for looking into this.
I joined the beta program and installed v 2.91b3 but unfortunately with this I still get the same effect as described above.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37734
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-06-21, 09:19 UTC

If you have some patience, I could send you a test version where I can check what the system returns. I guess that the privatemode uses a different address than TC expects, because currently this function is meant for SD-Cards and USB sticks only.

Please contact me by e-mail to support at ghisler dot com if you are interested.
Author of Total Commander
http://www.ghisler.com

Post Reply