Can't play video files anymore (.mpg .avi .mp4)

Support for Android version of Total Commander

Moderators: sheep, Hacker, Stefan2, white

Post Reply
sffww98
Junior Member
Junior Member
Posts: 4
Joined: 2019-01-21, 15:01 UTC

Can't play video files anymore (.mpg .avi .mp4)

Post by *sffww98 » 2019-01-21, 15:21 UTC

a week ago I could play .mpg .avi .mp4 by running TC and clicking on the video file.
Something changed and now I can't play any video. Occasionally a video will show an icon, like mp4 icon and it will play.
But most of the time, when I right click the file, it gives no "open with" choice. All it gives is choices like "add to queue" if a video failed and I didn't clear it or if music was playing. Another right click choice if there is nothing in the queue is "open as" with "picture, music, video, text" as the choices. Just a few minutes ago, a video had an icon and it played fine. a few minutes later, after trying other videos, I went back to the one that had played and now it has no icon and won't play.

I don't know where the error file is or any hidden features are located.

I'm running an Asus Chromebox 3. As far as I know, and I am not an experienced Android person, Android is current and TC is current. I uninstalled and reinstalled TotalCommander.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37667
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: can't play video files

Post by *ghisler(Author) » 2019-01-22, 15:25 UTC

TC shows these options depending on the file type. Are you sure they have the correct extension, and not some extra whitespace or so at the end?
Author of Total Commander
http://www.ghisler.com

sffww98
Junior Member
Junior Member
Posts: 4
Joined: 2019-01-21, 15:01 UTC

Re: can't play video files

Post by *sffww98 » 2019-01-22, 22:34 UTC

I am trying to open video with .mpg, .mp4, .avi. No spaces on the end.
the puzzling thing is the inconsistency. I could not get TC to play any videos or show me the TC Media Player in the Open with so I downloaded VLC.
In Total Commander I can now right click a video, select Play file (foreground) and it usually plays (VLC). If I select Open with, it pops a choice of a file folder icon and Open with * and */*. the only other choice on that original Open with is VLC, no TC Media Player as a choice. IF I choose the File folder option and scroll to TotalCmd (Queue) it can play in TC.
And sometimes, if I just select the video rather than right click, it plays fine but it can also pop an error "Cannot open file/folder" and the file path and name.

sffww98
Junior Member
Junior Member
Posts: 4
Joined: 2019-01-21, 15:01 UTC

Re: can't play video files

Post by *sffww98 » 2019-01-22, 22:57 UTC

There are errors but I am not familiar with where they are stored or how to read them.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37667
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Can't play video files anymore (.mpg .avi .mp4)

Post by *ghisler(Author) » 2019-01-24, 10:21 UTC

You could define an internal association in the main menu - Configure - Internal associations. This would bypass the default Android associations.
Author of Total Commander
http://www.ghisler.com

sffww98
Junior Member
Junior Member
Posts: 4
Joined: 2019-01-21, 15:01 UTC

Re: Can't play video files anymore (.mpg .avi .mp4)

Post by *sffww98 » 2019-01-24, 22:04 UTC

I can make an internal association but don't know either the format the association should take or what the name of the app or sub app should be. On the left side if the internal association I put .mpg on the right I have tried TC Media Player, TC Video Player, Total Commander, MediaPlayer and Media Player. entered just as shown, no slashes, dashes or any other markings.

Clicking once on the video generates a "Cannot Open file " along with the video name in the format shown when I queue a file. If I right click the video, there is no choice for "Open with" in Total Commander. the right click shows an "Open as" so I tried Video. it generates a "MediaPlayer playback error".

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37667
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Can't play video files anymore (.mpg .avi .mp4)

Post by *ghisler(Author) » 2019-01-28, 14:30 UTC

Just pick it with the >> button.
Author of Total Commander
http://www.ghisler.com

Post Reply