"Show" buttons frozen in Sync tool

The behaviour described in the bug report is either by design, or would be far too complex/time-consuming to be changed

Moderators: white, sheep, Hacker, Stefan2

Post Reply
browny
Senior Member
Senior Member
Posts: 220
Joined: 2007-09-10, 13:19 UTC

"Show" buttons frozen in Sync tool

Post by *browny »

I was comparing a subdirectory in zip archive and a directory.
"Equal" and "non-equal" buttons were checked. While it was still comparing the lists, I unchecked "equal" button.
Displayed list was correct, but then It was impossible to check or uncheck any buttons in the "Show" group, while everything else seemed to be working fine.
Closing and starting the tool changed nothing, hence TC had to be restarted.

A very rare thing to happen - maybe twice in 9.51, and now once in 10.0 b6 (both 64-bit).
Unfortunately, I have no idea how to reproduce this.
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40992
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: "Show" buttons frozen in Sync tool

Post by *ghisler(Author) »

Some people have reported before that the buttons could become unresponsive, but I was never able to reproduce it.
I will try with your instructions to reproduce it.
Author of Total Commander
http://www.ghisler.com
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40992
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: "Show" buttons frozen in Sync tool

Post by *ghisler(Author) »

Unfortunately I was not able to reproduce it. Does anyone know a way to reproduce this problem (not working buttons)?
Author of Total Commander
http://www.ghisler.com
browny
Senior Member
Senior Member
Posts: 220
Joined: 2007-09-10, 13:19 UTC

Re: "Show" buttons frozen in Sync tool

Post by *browny »

Today I noticed another strange behaviour when comparing several marked subdirectories with .7z archive contents.
The disk was quite busy at the time - all files on the same drive, and also a virtual machine was running in background (also on the same physical drive).
Only "not equal" button was checked. As it turned out, only one file was to be found.
While matching was in progress, several files were already processed as equal, some still had question marks, and in the visible part of the list one was non-equal. I used down arrow key to get to the file and pressed Ctrl+F3. Matching had completed while I was in compare tool, and when I closed the comparison window, the list in Sync tool still had several question marks, and only one file was "not equal".
I repeated matching process without any interference, and this time only that one file was left in the list.

My best guess is that interaction between the matching routine and the GUI has issues, so that data might get lost.
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40992
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: "Show" buttons frozen in Sync tool

Post by *ghisler(Author) »

Not confirmed, sorry. Maybe you closed the compare dialog with ESC, interrupting the sync tool comparison.
Author of Total Commander
http://www.ghisler.com
browny
Senior Member
Senior Member
Posts: 220
Joined: 2007-09-10, 13:19 UTC

Re: "Show" buttons frozen in Sync tool

Post by *browny »

Probably it was an Esc key, and response to keyboard events was slow due to processor and disk load. So I might have pressed it longer than usual or repeatedly. Thanks for the explanation.
Post Reply