Problem mit/with Bluetooth

Support for PocketPC and WinCE version

Moderators: sheep, Hacker, Stefan2, white

Olaschir
Junior Member
Junior Member
Posts: 35
Joined: 2005-03-07, 10:45 UTC
Location: bei Magdeburg

Post by *Olaschir » 2006-11-30, 13:15 UTC

Now, I've heard for some days, that the SDK fpr the WIDCOMM is now available - for nothing.

So I looked fpr the SDK. And I found these link:

http://www.broadcom.com/products/bluetooth_sdk.php

Can you check is this right, that's the SDK is now free?
And, so I hope for a TC-Pocket for Widcomm?

THX!

Thomas

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38145
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2006-11-30, 20:07 UTC

Hmm, where do you see that it's free? I'm getting to a registration dialog where there is a licence linked, which says
1. GRANT OF LICENSE. Subject to the terms and conditions of this Agreement and your payment to BROADCOM, Inc. (“BROADCOM”) of the fees specified in the invoice, BROADCOM grants the person or entity named in the invoice (“you”) the following license...
Author of Total Commander
http://www.ghisler.com

Olaschir
Junior Member
Junior Member
Posts: 35
Joined: 2005-03-07, 10:45 UTC
Location: bei Magdeburg

Post by *Olaschir » 2006-12-01, 09:32 UTC

I've read this in a magazin for PDAs in this week.
But I can't remember which magazin...
When I finished my work today, I look into the magazin.

Thomas

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38145
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2006-12-01, 21:03 UTC

Thanks, this would be really nice!
Author of Total Commander
http://www.ghisler.com

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38145
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2006-12-03, 17:19 UTC

Any news on that? I found some rumors on the net, e.g.
this one or here, but no official announcement from Broadcom...
Author of Total Commander
http://www.ghisler.com

User avatar
PuzoM
Junior Member
Junior Member
Posts: 45
Joined: 2005-04-20, 10:24 UTC

Post by *PuzoM » 2006-12-04, 13:04 UTC

ghisler(Author) wrote:Any news on that? I found some rumors on the net, e.g.
this one or here, but no official announcement from Broadcom...
Seems free to me now, just go to:
http://www.broadcom.com/products/bluetooth_sdk_download.php?filename=BTWCE-1_7_1_5201-SDK.zip
register and you'll get the link via mail:

Furthermore I got a HX4700 and bluetooth works fine in WM2003 SE.

Cheers.

Olaschir
Junior Member
Junior Member
Posts: 35
Joined: 2005-03-07, 10:45 UTC
Location: bei Magdeburg

Post by *Olaschir » 2006-12-04, 14:08 UTC

Sorry, could not found it.
But PuzoM wrote a good message...

And finally, it's free? Or is there any other license???

Thomas

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38145
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2006-12-04, 21:35 UTC

Well, the licence linked on the above page talks about a "fee to be paid to broadcom", that's why I think that it cannot be free...
Author of Total Commander
http://www.ghisler.com

User avatar
PuzoM
Junior Member
Junior Member
Posts: 45
Joined: 2005-04-20, 10:24 UTC

Post by *PuzoM » 2006-12-05, 08:57 UTC

ghisler(Author) wrote:Well, the licence linked on the above page talks about a "fee to be paid to broadcom", that's why I think that it cannot be free...
I registered myself via the link I posted above, got an email with a download link and now got file "BTWCE-1_7_1_5201-SDK.zip" No charges or anything, so YES it's FREE ;) (Indeed the license you talk about talks about fees, but it's a general license. No fees are specified in the invoice for the SDK download.)

Extraction from the readme.htm inside the zip:

Code: Select all

This version of the BTW-CE SDK allows you to create
Windows Mobile 5.0 applications using Visual Studio 2005, as well as
PocketPC 2003 applications using eMbedded Visual C++ 4.0 (with Service Pack 2).
You can deploy applications either to Windows Mobile 5.0 or PocketPC 2003
devices. This version does not support application development for the
emulator, PocketPC 2000 platforms nor Pocket2002 platforms.

The SDK is designed to work with all WIDCOMM BTW-CE
stack software versions 1.4.1.60 and newer on Windows Mobile 2003 for PocketPC
devices, and on all versions running on Windows Mobile 5.0 devices.
And as you not gonna ask any charge for tcmd pocket I think you free to use it ;) Then again perhaps a mail to Broadcom will clear all the doubts ;)
Last edited by PuzoM on 2006-12-05, 09:16 UTC, edited 2 times in total.

User avatar
Flint
Power Member
Power Member
Posts: 3222
Joined: 2003-10-27, 09:25 UTC
Location: Moscow, Russia
Contact:

Post by *Flint » 2006-12-05, 09:08 UTC

I can add the quotation from this page:
http://www.pocketpcdn.com/articles/articles.php?atb.set(c_id)=78&atb.set(a_id)=7800&atb.perform(details)=
Most Bluetooth-enabled Windows Mobile devices have either the Microsoft Bluetooth stack or the Widcomm stack. Unfortunately for developers, these stacks have very different APIs which makes code portability between devices a big problem. The Microsoft API is publicly available with since the Windows CE 4.2 SDK was published while Widcomm’s was a commercial product (and an expensive one at that) for quite some time. After Widcomm was acquired by Broadcom, this SDK has been made freely available from Broadcom’s site:

http://www.broadcom.com/products/bluetooth_sdk.php
Flint's Homepage: Full TC Russification Package, VirtualDisk, NTFS Links, NoClose Replacer, and other stuff!
 
Using TC 9.22a / Win7 x64 SP1, Win10 x64

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38145
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2006-12-06, 16:33 UTC

This version of the BTW-CE SDK allows you to create
Windows Mobile 5.0 applications using Visual Studio 2005, as well as
PocketPC 2003 applications using eMbedded Visual C++ 4.0 (with Service Pack 2).
That's very unfortunate - TC pocket is writen in EVC++ 3.0 to support all possible platforms from WinCE 2.0 upto WM5. EVC++4 cannot be installed in parallel. So unfortunately I cannot implement bluetooth support for this stack, sorry.
Author of Total Commander
http://www.ghisler.com

User avatar
Flint
Power Member
Power Member
Posts: 3222
Joined: 2003-10-27, 09:25 UTC
Location: Moscow, Russia
Contact:

Post by *Flint » 2006-12-06, 20:43 UTC

ghisler(Author) wrote:EVC++4 cannot be installed in parallel.
Hm... I have once or twice installed both eVC++3 and eVC++4 on the same machine and they both worked fine.
Flint's Homepage: Full TC Russification Package, VirtualDisk, NTFS Links, NoClose Replacer, and other stuff!
 
Using TC 9.22a / Win7 x64 SP1, Win10 x64

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38145
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2006-12-07, 19:39 UTC

And I had once installed a newer emulator, causing the olders to fail. Well, maybe I will try to install it under Vmware...
Author of Total Commander
http://www.ghisler.com

User avatar
Flint
Power Member
Power Member
Posts: 3222
Joined: 2003-10-27, 09:25 UTC
Location: Moscow, Russia
Contact:

Post by *Flint » 2006-12-07, 21:36 UTC

ghisler(Author) wrote:And I had once installed a newer emulator, causing the olders to fail.
Well, it all was long ago, so I have already forgotten which versions of SDKs, emulators etc. I have installed... :( Maybe, some combinations do not fail while the others cause the different versions to interfere...
Flint's Homepage: Full TC Russification Package, VirtualDisk, NTFS Links, NoClose Replacer, and other stuff!
 
Using TC 9.22a / Win7 x64 SP1, Win10 x64

lastbyte
Junior Member
Junior Member
Posts: 2
Joined: 2013-01-19, 14:21 UTC

+++ Widcomm BTW-CE SDK - urgent needed +++

Post by *lastbyte » 2013-01-19, 17:11 UTC

Please help me to find the last version of good known Widcomm BTWCE-1_7_1_5201-SDK.zip
because I can’t continue my urgent project based on the old HP iPAQ’s :(

It’s hard to believe, perhaps even conspiracy theory, the SDK file is removed from whole WWW! :shock:

Each link goes to broadcam, but instead BTWCE 1.7 SDK, only total new SDK 6.1 for PC only, can be downloaded. What is more mysterious, even a new WINCED SDK (for Android & Apple) can be download only theoretical, because the register form takes personal data and captchar from an user, but it can not be submited. I saw in the HTML source code, this can not works, due to address lack in the [action] property. There is also a lot of dead links, even on the sites in China, Russia, etc.

I saw in the message posted by user PuzoM at Mon Dec 04, 2006 7:04 am, he catch this file somewhere and it works fine on your hx4700.
Can you share your know-how here or send it to my email uniibank(&)gmail com please?
Seems free to me now, just go to:
....BTWCE-1_7_1_5201-SDK.zip
register and you'll get the link via mail:

Furthermore I got a HX4700 and bluetooth works fine in WM2003 SE.

Post Reply