FTP Plugin problem

Support for PocketPC and WinCE version

Moderators: sheep, Hacker, Stefan2, white

Mixx
Junior Member
Junior Member
Posts: 15
Joined: 2007-08-05, 10:44 UTC

FTP Plugin problem

Post by *Mixx » 2007-08-05, 10:48 UTC

Hi,

I use Total Commander on all devices I can get it running on. On my current Smartphone (Samsung i600 with WM5) I have a strange issue: I can connect to my account all right, for a second I see the entries in the directory flashing up but then the screen is cleared and nothing is displayed.

I do not have this problem on my PC or Pocket PC devices.

I just upgraded to PB 2.5 but it did not help.

Is this a config issue?
Thanxx, Mixx

Mixx
Junior Member
Junior Member
Posts: 15
Joined: 2007-08-05, 10:44 UTC

Post by *Mixx » 2007-08-05, 11:06 UTC

I tested this problem on a WM6 device, the HTC s721 (called VOX) that just came out. Same problem.
Thanxx, Mixx

User avatar
Gerry Busch
Member
Member
Posts: 112
Joined: 2003-09-28, 05:10 UTC
Location: Canada

Re: FTP Plugin problem

Post by *Gerry Busch » 2007-08-05, 20:07 UTC

By way of comparison, the FTP plugin has been 100% reliable on my Axim X51v (Windows Mobile 5), in both betas of version 2.5.

I have noticed, however, that after I use it to upload a file to my site, the updating process seems to reload the remote directory twice.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38395
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-08-06, 19:47 UTC

2Mixx
What do you mean exactly with "the screen is cleared"? Does Total Commander Pocket disappear as a whole, or does the file list become empty?

2Gerry Busch
Can you confirm that in the log file?

You can create a log file like this:
1. Use the registry plugin to go to
HKCU\Software\Ghisler\CECmd\Configuration
2. Double tap on "+Add value+"
3. Enter the name LogFile, type String
4. As contents, enter something like \log.txt
Author of Total Commander
http://www.ghisler.com

User avatar
Gerry Busch
Member
Member
Posts: 112
Joined: 2003-09-28, 05:10 UTC
Location: Canada

Post by *Gerry Busch » 2007-08-06, 20:02 UTC

OK, I just created that log file. After the login, I copied one file to the server (an overwrite) and logged back off. Here's are the log entries beyond the login stage. They seem to show more negotiations with the server than normal:

08/06/07 13:06:10: Connect ok!
08/06/07 13:06:10: SYST
08/06/07 13:06:10: 215 UNIX Type: L8
08/06/07 13:06:10: get directory...
08/06/07 13:06:10: TYPE A
08/06/07 13:06:11: 200 Type set to A.
08/06/07 13:06:11: PASV
08/06/07 13:06:11: 227 Entering Passive Mode (82,197,131,106,133,78).
08/06/07 13:06:11: LIST /foliage.atspace.com/
08/06/07 13:06:11: 150 Opening ASCII mode data connection for file list
08/06/07 13:06:11: Download
08/06/07 13:06:12: Waiting for server...
08/06/07 13:06:13: 226-Transfer complete.
08/06/07 13:06:13: 226 Quotas on: using 1052.43 of 51200.00 Kb
08/06/07 13:06:13: CONNECT \Atspace\
08/06/07 13:06:17: get directory...
08/06/07 13:06:17: PASV
08/06/07 13:06:17: 227 Entering Passive Mode (82,197,131,106,133,84).
08/06/07 13:06:17: LIST /foliage.atspace.com/
08/06/07 13:06:18: 150 Opening ASCII mode data connection for file list
08/06/07 13:06:18: Download
08/06/07 13:06:19: Waiting for server...
08/06/07 13:06:19: 226-Transfer complete.
08/06/07 13:06:19: 226 Quotas on: using 1052.43 of 51200.00 Kb
08/06/07 13:06:21: Upload file...
08/06/07 13:06:21: TYPE I
08/06/07 13:06:21: 200 Type set to I.
08/06/07 13:06:21: PASV
08/06/07 13:06:21: 227 Entering Passive Mode (82,197,131,106,133,88).
08/06/07 13:06:24: STOR /foliage.atspace.com/toc8.html
08/06/07 13:06:24: 150 Opening BINARY mode data connection for /foliage.atspace.com/toc8.html
08/06/07 13:06:24: Upload
08/06/07 13:06:25: 226 Transfer complete.
08/06/07 13:06:25: Copied \SD Card\Writing\Website\toc8.html -> /foliage.atspace.com\toc8.html, 3365 bytes, 5.6 kbytes/s
08/06/07 13:06:25: get directory...
08/06/07 13:06:25: TYPE A
08/06/07 13:06:25: 200 Type set to A.
08/06/07 13:06:25: PASV
08/06/07 13:06:25: 227 Entering Passive Mode (82,197,131,106,133,94).
08/06/07 13:06:26: LIST /foliage.atspace.com/
08/06/07 13:06:26: 150 Opening ASCII mode data connection for file list
08/06/07 13:06:26: Download
08/06/07 13:06:27: Waiting for server...
08/06/07 13:06:27: 226-Transfer complete.
08/06/07 13:06:27: 226 Quotas on: using 1052.43 of 51200.00 Kb
08/06/07 13:06:28: get directory...
08/06/07 13:06:28: PASV
08/06/07 13:06:28: 227 Entering Passive Mode (82,197,131,106,133,96).
08/06/07 13:06:29: LIST /foliage.atspace.com/
08/06/07 13:06:29: 150 Opening ASCII mode data connection for file list
08/06/07 13:06:29: Download
08/06/07 13:06:30: Waiting for server...
08/06/07 13:06:30: 226-Transfer complete.
08/06/07 13:06:30: 226 Quotas on: using 1052.43 of 51200.00 Kb
08/06/07 13:06:36: DISCONNECT \Atspace
08/06/07 13:06:36: QUIT
08/06/07 13:06:37: 221 Goodbye.
08/06/07 13:06:37: OFFLINE!
08/06/07 13:06:37: Closed Internet Connection.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38395
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-08-06, 20:37 UTC

That's very strange - I will try to reproduce it.
Author of Total Commander
http://www.ghisler.com

User avatar
Gerry Busch
Member
Member
Posts: 112
Joined: 2003-09-28, 05:10 UTC
Location: Canada

Post by *Gerry Busch » 2007-08-06, 20:53 UTC

ghisler(Author) wrote:That's very strange - I will try to reproduce it.
I wouldn't exclude the possibility that my server is causing this by using a different kind of script. I have an account on a different FTP server, and will try the same procedure on it.

User avatar
Gerry Busch
Member
Member
Posts: 112
Joined: 2003-09-28, 05:10 UTC
Location: Canada

Post by *Gerry Busch » 2007-08-06, 21:06 UTC

Gerry Busch wrote:I wouldn't exclude the possibility that my server is causing this by using a different kind of script. I have an account on a different FTP server, and will try the same procedure on it.
No, it did precisely the same thing on my other server, only much faster, since there are very few files in the directory.

Mixx
Junior Member
Junior Member
Posts: 15
Joined: 2007-08-05, 10:44 UTC

Post by *Mixx » 2007-08-06, 21:28 UTC

ghisler(Author) wrote:2Mixx
What do you mean exactly with "the screen is cleared"? Does Total Commander Pocket disappear as a whole, or does the file list become empty?
Hi, only the file list becomes empty, other than that TC controls are there. I did more investigation in the meantime and found that not all FTP sites display that behavior. The ones that do effect TC both on a PocketPC (WM 2003) and on Smartphones (WM5 and WM6).

In all cases: on a desktop PC using Windows XP the problem does not show.
Thanxx, Mixx

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38395
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-08-09, 15:39 UTC

2Mixx
Please try to create a log file, see the message above for step by step instructions.

2Gerry Busch
I have tried to reproduce this error, but the directory listing was read only once on my x51v.

I thought that it might be caused by the speicified remote directory /foliage.atspace.com/ , but when I tried this, I also got only one refresh. I specified the remote directory as
/foliage.atspace.com/
or
/foliage.atspace.com

no difference. Sorry, I have no idea what it could be, you probably have to live with it.
Author of Total Commander
http://www.ghisler.com

Mixx
Junior Member
Junior Member
Posts: 15
Joined: 2007-08-05, 10:44 UTC

Post by *Mixx » 2007-08-09, 21:01 UTC

ghisler(Author) wrote:2Mixx
Please try to create a log file, see the message above for step by step instructions.
Hi,

here is my logfile:

09.08.07 22:26:55: Connecting...
09.08.07 22:27:51: Making Internet Connection via Connection Manager...
09.08.07 22:27:51: Connection established!
09.08.07 22:27:51: Resolving server address...
09.08.07 22:27:51: Connecting...
09.08.07 22:27:52: Connect, waiting for login...
09.08.07 22:27:52: 220 Welcome to the most popular FTP hosting service! Save on hardware, software, hosting and admin. Share files/folders with read-write permission. Visit http://www.drivehq.com/ftp/
09.08.07 22:27:52: Logging in...
09.08.07 22:27:52: USER jreger
09.08.07 22:27:52: 331 User name ok, need password.
09.08.07 22:27:52: PASS *****
09.08.07 22:27:53: 230 User successfully logged on.
09.08.07 22:27:53: Connect ok!
09.08.07 22:27:53: SYST
09.08.07 22:27:53: 215 UNIX emulated by DriveHQ FTP Server.
09.08.07 22:27:53: get directory...
09.08.07 22:27:53: TYPE A
09.08.07 22:27:53: 200 Type set to A
09.08.07 22:27:53: PASV
09.08.07 22:27:54: 227 Entering Passive Mode (66,220,9,50,16,29).
09.08.07 22:27:54: LIST /
09.08.07 22:27:54: 150 Connection accepted
09.08.07 22:27:54: Download
09.08.07 22:27:54: Waiting for server...
09.08.07 22:27:55: 226 Transfer complete
09.08.07 22:27:55: CONNECT \driveHQ\
09.08.07 22:28:01: DISCONNECT \driveHQ
09.08.07 22:28:01: QUIT
09.08.07 22:28:01: 220 Bye
09.08.07 22:28:01: OFFLINE!
09.08.07 22:28:01: Closed Internet Connection.
Thanxx, Mixx

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38395
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-08-13, 15:58 UTC

09.08.07 22:27:55: 226 Transfer complete
As you can see, the directory listing is downloaded just fine.

I can only guess that the server sends the listing in a format which Total Commander Pocket cannot understand. Your only chance to make it work is to create a custom template in Total commander for Windows, and then use that in Total Commander Pocket. For this, you would have to put it in an ini file with the following format:

[Unix1]
Template1=pppppppppp !S* TTT DDDDDDDD n*

Of course you can't just use this template, you have to adapt it to your server.
Author of Total Commander
http://www.ghisler.com

Mixx
Junior Member
Junior Member
Posts: 15
Joined: 2007-08-05, 10:44 UTC

Post by *Mixx » 2007-08-13, 20:26 UTC

ghisler(Author) wrote:
09.08.07 22:27:55: 226 Transfer complete
As you can see, the directory listing is downloaded just fine.

I can only guess that the server sends the listing in a format which Total Commander Pocket cannot understand. Your only chance to make it work is to create a custom template in Total commander for Windows, and then use that in Total Commander Pocket. For this, you would have to put it in an ini file with the following format:

[Unix1]
Template1=pppppppppp !S* TTT DDDDDDDD n*

Of course you can't just use this template, you have to adapt it to your server.
OK. I'd try to that. How can I learn what the characters mean in the above specification.

Also: TC on the PC understands that format, I have no problems on the desktop.

Thanxx, Mixx
Thanxx, Mixx

User avatar
Gerry Busch
Member
Member
Posts: 112
Joined: 2003-09-28, 05:10 UTC
Location: Canada

Post by *Gerry Busch » 2007-08-14, 05:30 UTC

ghisler(Author) wrote: Gerry Busch
I have tried to reproduce this error, but the directory listing was read only once on my x51v.

I thought that it might be caused by the speicified remote directory /foliage.atspace.com/ , but when I tried this, I also got only one refresh. I specified the remote directory as
/foliage.atspace.com/
or
/foliage.atspace.com

no difference. Sorry, I have no idea what it could be, you probably have to live with it.
It's not really a big problem; I was only curious about it. By the way, how did you manage to get a directory listing without a password? Atspace.com has no anonymous FTP access that I know of.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38395
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2007-08-16, 15:41 UTC

2Gerry Busch
I haven't tested with Atspace, I have created a directory with that name on my own server and tried to connect to it...
Author of Total Commander
http://www.ghisler.com

Post Reply