REQUEST - allow cloning with COPY

Support for PocketPC and WinCE version

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
trids
Junior Member
Junior Member
Posts: 36
Joined: 2009-10-05, 09:01 UTC

REQUEST - allow cloning with COPY

Post by *trids » 2009-10-05, 09:43 UTC

Please could you make it possible to clone a file by copying it into the same directory as the original, and renaming it by adding a "1" before the extension?

EG: I want to clone a test.mscr script file, so I copy to clipboard and then when i paste, TC recognises that there is a file of that name already in the destination folder and offers to create a copy of it, which it calls test1.mscr -- and if i then copy and paste test1.mscr, it will create test11.mscr.

ouzoWTF
Junior Member
Junior Member
Posts: 93
Joined: 2009-04-20, 21:03 UTC

Post by *ouzoWTF » 2009-10-05, 12:27 UTC

CTRL+C and CTRL+V works for me. It adds a _2 before the extension. You do not have to use the two panels. But of course, it would be nice if using both panels and F5 the clone would be created the same way as described above.
Single User Licence #201763

User avatar
trids
Junior Member
Junior Member
Posts: 36
Joined: 2009-10-05, 09:01 UTC

Post by *trids » 2009-10-05, 12:50 UTC

That's weird! Mine throws up a dialog saying the file exists and giving me the following options only:
  • Overwrite
  • Overwrite all
  • Skip
  • Skip all
  • Overwrite all older
  • Cancel
I'm running TCP v 2.51 .. and you?

ouzoWTF
Junior Member
Junior Member
Posts: 93
Joined: 2009-04-20, 21:03 UTC

Post by *ouzoWTF » 2009-10-06, 00:07 UTC

Now I see something weird too. At work the name scheme of the clone is as described above with originalname_2.extension. As I tried it now at home the clone it is named like that: Copy of originalnameextension
Single User Licence #201763

User avatar
trids
Junior Member
Junior Member
Posts: 36
Joined: 2009-10-05, 09:01 UTC

Post by *trids » 2009-10-06, 05:39 UTC

:shock: .. are we both talking about Total Commander Pocket? Version 2.51?

ouzoWTF
Junior Member
Junior Member
Posts: 93
Joined: 2009-04-20, 21:03 UTC

Post by *ouzoWTF » 2009-10-06, 06:44 UTC

ähm... no. Sorry, I just... omg :X
Seems like I cant help you.

But my weird behavior persists. I try too find out more and maybe open a separate thread. Sorry again.
Single User Licence #201763

Post Reply