SVNDetails - TortoiseSVN content plugin

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: sheep, Hacker, Stefan2, white

Post Reply
thein
Junior Member
Junior Member
Posts: 41
Joined: 2008-01-07, 15:04 UTC
Location: Aachen, Germany
Contact:

Post by *thein » 2016-01-11, 16:14 UTC

Ok, I haven't used the x86-version of TC for years now. I'll try to reproduce and fix this issue next week...

tc_kaan
Junior Member
Junior Member
Posts: 2
Joined: 2016-09-19, 06:54 UTC

Post by *tc_kaan » 2016-09-19, 07:06 UTC

thein wrote:Have you installed the correct Visual Studio 2015 Redistributable Components (i. e. VC_redist_x64.exe / VC_redist_x86.exe)?
Hi guys, I work under user account, don't have a possibility to install vc components. Do you know if it is possible just to find and put required files in the same folder where I have the plugin (or in any folder I have in %PATH%)?

tc_kaan
Junior Member
Junior Member
Posts: 2
Joined: 2016-09-19, 06:54 UTC

Post by *tc_kaan » 2016-11-14, 11:04 UTC

Hi guys,

Not sure if the thread is alive, but if somebody still visit it, could you please let me know where SVNDetails v2.10 can be found? it is the last version that do not require VC redist files on my office pc.

Thanks!

User avatar
kluvi
Junior Member
Junior Member
Posts: 40
Joined: 2010-02-18, 11:13 UTC
Location: Czech rep.

Post by *kluvi » 2018-03-21, 14:53 UTC

Hi. I have problem with TC ans SVNdetails.
i used 64bit TC 9.12 under WIN10-64 with
TortoiseSVN-1.9.7.27907-x64-svn-1.9.7.msi
and
wdx_SVNDetails_v3.00
and it worked fine (i think).

Now i was pushed to downgrade to
TortoiseSVN-1.7.15.25753-x64-svn-1.7.18.msi
After some story (described later) it is in state that when i quit TC with panel with SVNDetails displayed, and start TC again, TC crashes.
When i rename plugin directory TC starts OK, change panel to non-SVNDetail infos, then rename plugin dir to correct name, restart TC: everything works ok.
When i quit TC and start again, it works fine.
But when i forget SVNDetail ON again before quitting TC, it starts to crash again.
-----------------------------------
Original story which maybe caused this situation was:
i used TC 9.12 with
TortoiseSVN-1.9.7.27907-x64-svn-1.9.7.msi
and
wdx_SVNDetails_v3.00
and it worked fine (i think).

Now i was pushed to downgrade to
TortoiseSVN-1.7.15.25753-x64-svn-1.7.18.msi

It stopped showing any SVN info in columns, but after while i realised that i should delete and re-checkout directories under older version.
Inbetween i upgraded SVNDetails to 3.10 but it miss some DLL
I loaded again SVNDetail3.10 but it fail by starting as i described at beginning.
Can someone check it, please?
For instance if you have SVN 1.7 and TC with SVNDetail 3.10 - is it working fine?
If Yes, it happenned something whil my toggling SVN versions)
If NO, there is probably som problem with plugin....
Thak you in advance.
Martin

User avatar
sqa_wizard
Power Member
Power Member
Posts: 3508
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Post by *sqa_wizard » 2018-03-21, 22:58 UTC

For instance if you have SVN 1.7 and TC with SVNDetail 3.10 - is it working fine?
SVNDetail 3.10 supports TortoiseSVN 1.9.x
SVNDetail 3.02 supports TortoiseSVN 1.7.x

Download see here
#5767 Personal license

User avatar
kluvi
Junior Member
Junior Member
Posts: 40
Joined: 2010-02-18, 11:13 UTC
Location: Czech rep.

Post by *kluvi » 2018-03-22, 06:51 UTC

Hi.
I am not able to install SVNdetail 3.10 because of error message "some DLL is missing" I have seen some post that you have to install 32bit TSVN but i am not able to do it because of my WIN10-64

I try to use SVNDetail3.0 and TSVN1.7 which have to be compatible...

I tested it on my colleague's computer and it works fine there. Difference is that he has WIN7-64 and never had TSVN1.9. installed and never tried to install SVNDetail3.10

User avatar
kluvi
Junior Member
Junior Member
Posts: 40
Joined: 2010-02-18, 11:13 UTC
Location: Czech rep.

Post by *kluvi » 2018-03-22, 07:30 UTC

Now i tested on 2nd computer (identical with mine) and error is REPRODUCIBLE!
there was already TSVN1.7 identical to mine, Subversion is 1.7.18
I upgraded TC from 9.0 to 9.12, installed SVNDetails3.0
and it crashes at start when TSVN columns was displayed before

User avatar
kluvi
Junior Member
Junior Member
Posts: 40
Joined: 2010-02-18, 11:13 UTC
Location: Czech rep.

Post by *kluvi » 2018-03-22, 09:22 UTC

by the way...while doing those test my default.bar was switched from user profile to program dir...

User avatar
sqa_wizard
Power Member
Power Member
Posts: 3508
Joined: 2003-02-06, 11:41 UTC
Location: Germany

Post by *sqa_wizard » 2018-03-22, 22:54 UTC

I upgraded TC from 9.0 to 9.12, installed SVNDetails3.0
You may install at least SVNDetail 3.02 (download from this thread)
Version history wrote:Version 3.10 (20150903)
CHANGE: Supports TortoiseSVN 1.9.x
CHANGE: Update project to Microsoft Visual Studio 2015

Version 3.02 (20130620)
BUGFIX: Crash on Windows 8 if no TortoiseSVN shell icons are being displayed (Thanks to tufftaeh for
reporting this error)

Version 3.01 (20130205)
BUGFIX: Crash on Windows 8
#5767 Personal license

User avatar
kluvi
Junior Member
Junior Member
Posts: 40
Joined: 2010-02-18, 11:13 UTC
Location: Czech rep.

Post by *kluvi » 2018-03-23, 07:52 UTC

Great! It helped.
I have seen that release info, but description is confusing for me (overlay icons WERE displayed )
Another funny thing is, that i had no problems when using SVNDetail3.0 with TSVN 1.9...
Thanks for You help.

Post Reply