[WLX] MMedia 2.62 x32/x64 Unicode/ANSI (Sep 2014)

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr »

Hello krasusczak,

First, thanks for all this tests
krasusczak wrote: hmm today i have little more time & from my tests i have this:

1).
when i have
mmedia.wlx (2, 6, 0, 0 ansi NoDL)
mediainfo.dll (0.7.68.0)

plugin works
when i play mp3 without option "Use Mediainfo for MP3" i get normal/old info
when i play mp3 with option "Use Mediainfo for MP3" i get info from Mediainfo

when i play ogg without option "Use Mediainfo for MP3" i get error "Unable to load MediaInfo.dll"
OK, I get the same error, I will correct it
krasusczak wrote: when i play ogg with option "Use Mediainfo for MP3" i get info from Mediainfo


2).
when i have
mmedia.wlx (2, 6, 0, 0 ansi NoDL)
mmedia.uwlx (2, 6, 0, 0 unicode NoDL)
mediainfo.dll (0.7.68.0)

plugin works
when i play mp3 without option Use Mediainfo for MP3 i get normal/old info
when i play mp3 with option Use Mediainfo for MP3 i get normal/old info

when i play ogg without option Use Mediainfo for MP3 i get blank space in info
when i play ogg with option Use Mediainfo for MP3 i get blank space in info


3).
when i have only
mmedia.uwlx (2, 6, 0, 0 unicod NoDL) [named as mmedia.uwlx or mmedia.wlx]
mediainfo.dll (0.7.68.0)

plugin crash
I can't reproduce this on my PC.
if I'm using unicode version with ext wlx : I obtain the following message : "Crash in plugin mmedia.wlx:ListLoadW"
if I rename it with ext uwlx : plugin works
krasusczak wrote: My questions:P
1. do i need both files ansi & unicode to run unicode??
no, ANSI & unicode can coexist if you want to use both TC32 and TC64 and keep only one plugin folder for both.
krasusczak wrote: 2. "Use Mediainfo for MP3" what exactly this mean only MP3 files or all music files..? because if i understand this correctly if selected only mp3 files should be affected not ogg & rest...
You understood well, but it seems there is a bug.
krasusczak wrote: 3. when i have ansi, ansi & unicode why there is problem with localize mediainfo.dll
that's the question I will try to solve!!
krasusczak
Senior Member
Senior Member
Posts: 267
Joined: 2011-09-23, 10:35 UTC

Post by *krasusczak »

fg_2002fr wrote: I can't reproduce this on my PC.
if I'm using unicode version with ext wlx : I obtain the following message : "Crash in plugin mmedia.wlx:ListLoadW"
if I rename it with ext uwlx : plugin works

Ok i just check one more time unicode only & i just realize that i forget about one little thing:


0=%COMMANDER_PATH%\plugins\wlx\Mmedia\mmedia.wlx
file: mmedia.wlx
crash

0=%COMMANDER_PATH%\plugins\wlx\Mmedia\mmedia.uwlx
file: mmedia.wlx
doesn't work (normal..)

0=%COMMANDER_PATH%\plugins\wlx\Mmedia\mmedia.uwlx
file: mmedia.uwlx
crush

0=%COMMANDER_PATH%\plugins\wlx\Mmedia\mmedia.wlx
file: mmedia.uwlx
Works :P





@p.s.
update (c) year in Info "Copyrigth (c) 2002 - 2013 François GANNIER" xD
Last edited by krasusczak on 2014-06-30, 13:47 UTC, edited 2 times in total.
User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr »

krasusczak wrote: 0=%COMMANDER_PATH%\plugins\wlx\Mmedia\mmedia.uwlx
file: mmedia.uwlx
crush

0=%COMMANDER_PATH%\plugins\wlx\Mmedia\mmedia.wlx
file: mmedia.uwlx
Works :P
oh yes, I forgot to say that section [listerplugin] in wincmd.ini always need to point to wlx (even when wlx files aren't present)
Plumber
Junior Member
Junior Member
Posts: 12
Joined: 2014-04-25, 14:05 UTC

Post by *Plumber »

Mmedia 2.60 x32 plugin writes mmedia.ini in %Commander_Path% but x64 works with that which is in plugin folder
It would be nice to have a setting in the plugin options, which sets the path to the mmedia.ini file and to MediaInfo.dll
User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr »

Yes, this is a bug with the new unicode version of MMedia 32b.
it will be corrected in the next release.
iana
Senior Member
Senior Member
Posts: 343
Joined: 2010-07-27, 22:00 UTC

Post by *iana »

For starters I want to tank you for a great plugin, love all your plugins.

a question/suggestion, seeing how all ansi windows (9x branch) are dead or unsupported and all 64bit are unicode what's the point of developing 8 versions of this plugin, when the plugin itself needs a Unicode application (Windows Media Player) to run?

My suggestion is drop the ansi versions and don't use the uwlx suffixes, a lot of users are going to be confused with too many versions of this same plugin, at the moment there are 8 versions of this plugin: 4 32 bit (static and dynamic ansi and static and dynamic unicode) and 4 64 bit (but 64 bit OS's are unicode), I shouldn't be splitting hairs as I use your dynamic unicode 32 bit but the latest update left me with 2 plugins an old *.wlx and a new *.uwlx :/
My idea is keep the number of versions of this plugin to a low 4.

sorry if I was ranting :(
krasusczak
Senior Member
Senior Member
Posts: 267
Joined: 2011-09-23, 10:35 UTC

Post by *krasusczak »

Hi iana you can del old *.wlx & use only new *.uwlx all will works fine ;)
krasusczak
Senior Member
Senior Member
Posts: 267
Joined: 2011-09-23, 10:35 UTC

Post by *krasusczak »

Hi, any news about new fixed version?
User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr »

krasusczak wrote:Hi, any news about new fixed version?
MMedia ver 2.61
------------------
- Added : scrollbar for "Options" tab
- Added : Custom Path for Mediainfo
- Added : Show version of Mediainfo
- Fixed : Display Media information for MP3 if 'use Mediainfo for MP3' is checked but MI DLL not found
- Fixed : Unicode&32 : mmedia.ini in WLX folder was not used
- Fixed : Unicode&32 : "Unable to load Mediainfo"
- Fixed : Some MP3 incompatibilities

You can download it here:
Unicode version
ANSI version

Size: 1MB

see webpage for others plugins at:
http://fg.tcplugins.free.fr/
krasusczak
Senior Member
Senior Member
Posts: 267
Joined: 2011-09-23, 10:35 UTC

Post by *krasusczak »

I just tested it & works great thanks!


p.s good idea with scrollbar for option, I forget to mention about that ;).

p.s2 only download from your website works, download from totalcmd.net/wincmd.ru goes to: wlx_mmedia260u.zip & mirror goes to buggy zip file: wlx_mmedia_2.61.zip


@edit:
p.s3
now i only miss mouse scroll wheel function on this option window;D


@edit2:
I found some problem with playlist, when you start playlist & you go to ID3Tag V2 tab to do something & you gonna back to playlist & change song twice you will get all the time this: "Un argument non valide a été détecté", playlist stop working, music play until end of the song & no information in "Media Information"

The same error=plugin crash we gonna have when we select a few songs, open, change tab to ID3 V2 back to Media Information & double click ">>" = External exception E06D7363
User avatar
Dalai
Power Member
Power Member
Posts: 7317
Joined: 2005-01-28, 22:17 UTC
Location: Meiningen (Südthüringen)

Post by *Dalai »

krasusczak wrote:p.s2 only download from your website works, download from totalcmd.net/wincmd.ru goes to: wlx_mmedia260u.zip & mirror goes to buggy zip file: wlx_mmedia_2.61.zip
This was an issue with the totalcmd.net site which is fixed now (I had the same issue with my Services2 plugin). In other words: The mirror link works now.

Regards
Dalai
#101164 Personal licence
Ryzen 5 2600, 16 GiB RAM, ASUS Prime X370-A, Win7 x64

Plugins: Services2, Startups
krasusczak
Senior Member
Senior Member
Posts: 267
Joined: 2011-09-23, 10:35 UTC

Post by *krasusczak »

Dalai wrote:
krasusczak wrote:p.s2 only download from your website works, download from totalcmd.net/wincmd.ru goes to: wlx_mmedia260u.zip & mirror goes to buggy zip file: wlx_mmedia_2.61.zip
This was an issue with the totalcmd.net site which is fixed now (I had the same issue with my Services2 plugin). In other words: The mirror link works now.

Regards
Dalai

nope sorry, not for me at least problem still persist ;)
User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr »

krasusczak wrote:p.s2 only download from your website works, download from totalcmd.net/wincmd.ru goes to: wlx_mmedia260u.zip & mirror goes to buggy zip file: wlx_mmedia_2.61.zip
Thanks, this is corrected
User avatar
fg_2002fr
Senior Member
Senior Member
Posts: 267
Joined: 2003-02-24, 10:12 UTC
Location: Tours (France)
Contact:

Post by *fg_2002fr »

krasusczak wrote: I found some problem with playlist, when you start playlist & you go to ID3Tag V2 tab to do something & you gonna back to playlist & change song twice you will get all the time this: "Un argument non valide a été détecté", playlist stop working, music play until end of the song & no information in "Media Information"
OK, I confirm this bug. I will try to correct it.
krasusczak
Senior Member
Senior Member
Posts: 267
Joined: 2011-09-23, 10:35 UTC

Post by *krasusczak »

the same bug i have with Lyrics tab but in this case after you change from Lyrics tab to Media Information you need to change to the other song & then back to this song with lyrics..
Post Reply