New: Windows Media Audio v2 (MTP, PlaysForSure) plugin

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: sheep, Hacker, Stefan2, white

Post Reply
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37695
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

New: Windows Media Audio v2 (MTP, PlaysForSure) plugin

Post by *ghisler(Author) » 2011-12-15, 15:37 UTC

My old Windows Media Audio (Media Transfer Protocol) plugin could not be ported to 64-bit, so I have written a new one using the new WPD (Windows Portable Devices) functions. These are available for both 32-bit and 64-bit, but require Windows Media Player 10 or newer.

This plugin can be used to access media players and tablets which do not show up with a drive letter in Windows.

The plugin is available in 32-bit and 64-bit with full source code. It's faster than the old plugin, so I'm offering it also for 32-bit.

Download: WPD plugin final version (32/64) | Sources

Please report any problems in this thread.

Currently media files are uploaded with metadata like title, artist etc. set, but not with any preview image. I do not have a player which can show images, so please contact me if you have such a player and would like to help test this missing function.

Christian Ghisler
Last edited by ghisler(Author) on 2013-10-01, 16:39 UTC, edited 3 times in total.
Author of Total Commander
http://www.ghisler.com

User avatar
Alextp
Power Member
Power Member
Posts: 2321
Joined: 2004-08-16, 22:35 UTC
Location: Russian Federation
Contact:

Post by *Alextp » 2011-12-15, 17:05 UTC

Notes
-"Description" string in .txt. Is it Ok? Not ok english?
-pls, can u put History lines in separate History.txt? Its hard for all ur plugs to see em in Readme, at end.
Ver. num (top of readme): no need here, History is enough.

User avatar
Sir_SiLvA
Power Member
Power Member
Posts: 2790
Joined: 2003-05-06, 11:46 UTC

Post by *Sir_SiLvA » 2011-12-15, 18:42 UTC

Sorry I disagree I prefer the first line WITH Version number
and History at the end like other readmes do it too...

and yes i guess
This plugin the Windows Portable Devices interface to access media players
and some other devices like Android tablets.
should be
This plugin uses the Windows Portable Devices interface to access media players
and some other devices like Android tablets.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37695
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2011-12-16, 09:44 UTC

Thanks for your correction - did you test the actual plugin too?
Author of Total Commander
http://www.ghisler.com

User avatar
EricB
Senior Member
Senior Member
Posts: 333
Joined: 2008-03-25, 22:21 UTC
Location: The Netherlands

Post by *EricB » 2011-12-16, 09:53 UTC

Christian,

First of all: awesome that you took the time to convert the existing plugin to WPD. Thanks for that!

I did some preliminary testing and found some problems:

- I used Win7x64 Professional, TC8Beta12 x32 using the WPD plugin x32 and my Creative Zen player
- When copying music from the player, every file gets timestamp 01/01/1980 00:00. I would propose current date, if original date cannot be retrieved
- Copying has no background threading, but this is more of a wish
- When copying already existing file to player, in overwrite dialog the timestamp of the target on player is very odd: 31/12/2559 60:16:60. Despite this, the overwrite all older option takes this as older, so everything is overwritten
- When copying an album of music files to artist folder on player, this happens very fast, but this results in zero byte files in the album (works correctly with the old MediaAudio version)
- When going into the folder on the player (emptying it) and copying individual files, I get an 'Error uploading file', resulting in 0 byte files. Same problem probably, but copying folder will suppress errors?
- When I copy Artist folder with albums subfolder in one go, only the Artist folder is created on player and it seems locked, I cannot access it using the plugin. Folder can be accessed with old plugin, but is empty
- When disconnecting and reconnecting the plugin, the folder can be accessed again. Some locking/caching problem?
- At some point, the FTP log is not registering anymore (the info logged is sparse anyway)

So it seems some work needs to be done for the upload part.

Regards, EricB

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37695
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2011-12-16, 09:57 UTC

Strange, I have no problems at all copying files to my device. Could you try with other files, e.g. txt or jpg?
Author of Total Commander
http://www.ghisler.com

User avatar
EricB
Senior Member
Senior Member
Posts: 333
Joined: 2008-03-25, 22:21 UTC
Location: The Netherlands

Post by *EricB » 2011-12-16, 10:04 UTC

JPG or txt render same problem. I just checked and did not find a normal copy of WMPlayer.exe on my system, only in winsxs. That might be the culprit. I can try a separate install after download. I remember that for the previous version of the plugin, the wmplayer itself was not necessary, but the framework was required. Is it the same in this case?

Regards, EricB
Regards, EricB

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37695
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2011-12-16, 11:23 UTC

Yes, it's the same, the player itself isn't necessary. However, you may have an outdated version of the framework - so far I could test the plugin only with WMP11. Therefore it may help to install the latest version of Windows Media Player to update the framework.
Author of Total Commander
http://www.ghisler.com

User avatar
EricB
Senior Member
Senior Member
Posts: 333
Joined: 2008-03-25, 22:21 UTC
Location: The Netherlands

Post by *EricB » 2011-12-16, 11:57 UTC

Unfortunately that's not possible. WMP12 is integrated in Win7, and I have SP1 and all latest updates. There is no standalone version for download, and the separate pack for N versions of Win7 will not install. It looks like WMP12 on my current machine is either corrupt or disabled by policy.

I'm going to try this at another machine which has Win7 with WMP12, but can only do this in the evening.

Regards, EricB

User avatar
EricB
Senior Member
Senior Member
Posts: 333
Joined: 2008-03-25, 22:21 UTC
Location: The Netherlands

Post by *EricB » 2011-12-16, 21:29 UTC

Christian,

Just tested on my laptop with Win7 HomePremium x32 and this time TC 7.56 (TC version should not matter, right?). This machine has the WMP 12 fully present. I see the exact same behaviour as reported before, so upload is impossible.

I'm willing to do some more testing with extended logging. My Zen player is able to display pictures BTW.

Regards, EricB

User avatar
petermad
Power Member
Power Member
Posts: 8544
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad » 2011-12-16, 23:57 UTC

I have tested it under my Windows 7 x64 in both 32bit and 64 bit versions.

I am not quite sure which devices I am supposed to see with the plugin (I don't have an MP3player), but it shows me my memory card reader, and in a subfolder to that the memory card drive letter. Copying files FROM a memory card with this plugin works OK, but when copying files TO the memory card, the file date is set to current date and time plus 1 hour.

The plugin does not show anything when run under Win XP 32bit whereas the old MediaAudio plugin (wmdmplug.wfx) shows the drive letters of my memory card reader plus my Nero Fast CD-Burning Plug-in. Shouldn't the two plugins show somewhat the same? - they do under Win 7 x64. Under Win XP the FTP connection window over the file panel is NOT opened when clicking on the MediaAudio2 entry..
License #524 (1994)
Danish Total Commander Translator
TC 9.5b1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1903) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 37695
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2011-12-18, 15:15 UTC

The plugin does not show anything when run under Win XP 32bit whereas the old MediaAudio plugin (wmdmplug.wfx) shows the drive letters of my memory card reader plus my Nero Fast CD-Burning Plug-in. Shouldn't the two plugins show somewhat the same?
The plugin is mainly meant for MP3 players which show up in Windows Media Player. Which version of WMP do you have on that computer? Does the card reader show up in Windows Media Player?
Author of Total Commander
http://www.ghisler.com

User avatar
petermad
Power Member
Power Member
Posts: 8544
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad » 2011-12-18, 17:21 UTC

I have Windows Media Player 11.
Yes, the card reader shows up in Windows Media Player - but only with the slots where there is a card inserted. In contrary to the old MediaAudio plugin (wmdmplug.wfx) or Winsdows Explorer where all 4 slots are always shown.
License #524 (1994)
Danish Total Commander Translator
TC 9.5b1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1903) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
EricB
Senior Member
Senior Member
Posts: 333
Joined: 2008-03-25, 22:21 UTC
Location: The Netherlands

Post by *EricB » 2011-12-18, 22:07 UTC

Additional observation:

Plugin also works for my Canon digital camera, which does not show up with a drive letter in Windows or TC. This is definitely something the old MediaAudio plugin could not do. The only con is that file dates of pictures on the camera are not shown and copying results in file dates of 01-01-1980. I feel that adjusting this behaviour alone (use EXIF date) will already lead to a proper replacement for the WiaCam plugin, which stopped working in Vista and Windows 7.

Regards, EricB

User avatar
petermad
Power Member
Power Member
Posts: 8544
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Post by *petermad » 2011-12-19, 01:56 UTC

If I attach my Canon Powershot camera to the USB port of my Win 7 x64 pc, it turns up in MediaAudio2 (but not in the old MediaAudio)

But at the same time the entry for my Memory card reader (Sd-kort 8gb) gets replaced by some very long dir-name - see: http://madsenworld.dk/tcmd/mediaaudio2.png

If I connect the same camera to my Win XP 32bit computer (with WMP 11), it does not turn up in MediaAudio2

The camera can also be seen in Explorer, and in TC using cm_OpenDrives (that applies to both my Win XP and my Win 7 x64 computer).
License #524 (1994)
Danish Total Commander Translator
TC 9.5b1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1903) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

Post Reply