LAN Plugin for Total Commander on Android not working anymor

Support for Android version of Total Commander

Moderators: sheep, Hacker, Stefan2, white

hy
Junior Member
Junior Member
Posts: 6
Joined: 2015-10-19, 19:53 UTC

LAN Plugin for Total Commander on Android not working anymor

Post by *hy » 2018-03-08, 10:47 UTC

Hi, since a couple of days the lan plugin for Samba shares doesn't work anymore.
guest@hostname is not allowed on my machine and though I have provided username and password correctly it tries to connect as guest and not with the given username.
any solution? Thanks in advance

User avatar
Stefan2
Power Member
Power Member
Posts: 2672
Joined: 2007-09-13, 22:20 UTC
Location: Europa

Post by *Stefan2 » 2018-03-08, 11:09 UTC

Hi hy,

which Plugin?
Name? Version?

Which TC version? Bit-ness?

Which OS? Bit-ness?


Do you have changed something on your system in the last couple of days?



TIA
Inofficial FAQs || WIKI (Deu/Eng) || TC Home (What's new? // FAQ // Download // Order // Addons // Tools // Plugins)
Erst wenn der letzte Baum gefällt oder die letzte Biene verendet ist, werden die Leute verstehen warum Umweltschutz wichtig ist.

hy
Junior Member
Junior Member
Posts: 6
Joined: 2015-10-19, 19:53 UTC

Post by *hy » 2018-03-08, 21:12 UTC

Stefan2 wrote:Hi hy,

which Plugin?
TotalCmd-LAN(Windows shares)
Android
Stefan2 wrote:Name? Version?
Version 3.04
Stefan2 wrote: Which TC version? Bit-ness?
don't know - where Do I find it?
Stefan2 wrote: Which OS? Bit-ness?
Stefan2 wrote: Do you have changed something on your system in the last couple of days?
I am on linux and do a dist upgrade every other day... but there were no changes in SAMBA to my knowledge


TIA

User avatar
Stefan2
Power Member
Power Member
Posts: 2672
Joined: 2007-09-13, 22:20 UTC
Location: Europa

Post by *Stefan2 » 2018-03-09, 08:29 UTC

Ok, thanks for clarifying!

Me thinks this should be moved to Android sub forum then.



> Which TC version?
Android-Version des Desktop-Dateimanagers Total Commander
https://play.google.com/store/apps/details?id=com.ghisler.android.TotalCommander&hl=de


> which Plugin?
LAN-Plugin v3.04 für Total Commander-for-Android
Note, there is already a v3.05 available:
https://play.google.com/store/apps/details?id=com.ghisler.tcplugins.LAN&hl=de



> Which OS?
Linux



> Problem:
the lan plugin for Samba shares tries to connect as guest and not with the given username.





 
Inofficial FAQs || WIKI (Deu/Eng) || TC Home (What's new? // FAQ // Download // Order // Addons // Tools // Plugins)
Erst wenn der letzte Baum gefällt oder die letzte Biene verendet ist, werden die Leute verstehen warum Umweltschutz wichtig ist.

hy
Junior Member
Junior Member
Posts: 6
Joined: 2015-10-19, 19:53 UTC

Post by *hy » 2018-03-09, 09:24 UTC

Stefan2 wrote:Ok, thanks for clarifying!

Me thinks this should be moved to Android sub forum then.
I thought this was the android subforum
Stefan2 wrote:
> Which TC version?
Android-Version des Desktop-Dateimanagers Total Commander
https://play.google.com/store/apps/details?id=com.ghisler.android.TotalCommander&hl=de
Android 7.0
TC: 2.80
Stefan2 wrote:
> which Plugin?
LAN-Plugin v3.04 für Total Commander-for-Android
Note, there is already a v3.05 available:
https://play.google.com/store/apps/details?id=com.ghisler.tcplugins.LAN&hl=de
3.05 is already installed
Stefan2 wrote:
> Which OS?
Linux
Stefan2 wrote:

> Problem:
the lan plugin for Samba shares tries to connect as guest and not with the given username.

 
Exactly that is. And linux prevents me from creating a user guest with any rights.
Thanks for trying

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38427
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-03-12, 14:46 UTC

The plugin first tries to login with the provided credentials. If this fails, it tries guest. The plugin should also ask for a password when you didn't enter any.
Author of Total Commander
http://www.ghisler.com

SteveBak
New Member
New Member
Posts: 1
Joined: 2018-03-25, 16:50 UTC

Post by *SteveBak » 2018-03-25, 16:52 UTC

I have the same issue.
TC = 2.90
Lan = 3.06
Android : 7.0

Can you help us out ?

Many thanks

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38427
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-03-26, 13:45 UTC

Try saving the password with a master password.
Author of Total Commander
http://www.ghisler.com

petrmatula
Junior Member
Junior Member
Posts: 4
Joined: 2018-04-06, 21:03 UTC

Post by *petrmatula » 2018-04-06, 21:20 UTC

I have the same problem.

LAN Plugin version 3.01-3.06 is not able to login on my samba server on opensuse linux at all.

LAN Plugin 3.0 is able to login when username and password are inserted in configuration.
When password is empty and ii'm asked for password during making a connection, the connection is rejected.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38427
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-04-09, 14:18 UTC

Thanks for the hint. There are two major differences between 3.0 and 3.01:

1. Trailing spaces (spaces at the end) of the user name, password, or path are now being removed. If you password does end with a space, you will not be able to log in.

2. The new version should better handle when the user entered the server name/path in an unusual or wrong way. But it may not work any more in some such cases. Therefore please make sure that you entered the server name in the correct way. The following are correct ways:
servername
servername/share
domain:servername
domain:servername/share

The following are incorrect:
\\servername\share
//servername/share
servername\share

Did you use any of these?
Author of Total Commander
http://www.ghisler.com

petrmatula
Junior Member
Junior Member
Posts: 4
Joined: 2018-04-06, 21:03 UTC

Post by *petrmatula » 2018-04-11, 15:11 UTC

1. I don't use spaces at the end.
2. I use servername only.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38427
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-04-12, 10:23 UTC

Unfortunately I don't see any other reason why it wouldn't work then. Could you try to install the older plugin version? If it doesn't work any longer either, then something on the server side must have changed.
Author of Total Commander
http://www.ghisler.com

petrmatula
Junior Member
Junior Member
Posts: 4
Joined: 2018-04-06, 21:03 UTC

Post by *petrmatula » 2018-04-12, 21:07 UTC

I'm using plugin 3.0 right now.
LAN Plugin 3.0 is able to login when username and password are inserted in configuration in advance.
When password is empty and i'm asked for password during making a connection, the connection is rejected.

petrmatula
Junior Member
Junior Member
Posts: 4
Joined: 2018-04-06, 21:03 UTC

Post by *petrmatula » 2018-04-12, 21:20 UTC

This is log from my samba server (LAN plugin 3.0.6)

/var/log/samba/log.smbd 5342/5342 100%
[2018/04/12 21:04:20.588548, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'gssapi_spnego' registered
[2018/04/12 21:04:20.588589, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'gssapi_krb5' registered
[2018/04/12 21:04:20.588607, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'gssapi_krb5_sasl' registered
[2018/04/12 21:04:20.588623, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'spnego' registered
[2018/04/12 21:04:20.588639, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'schannel' registered
[2018/04/12 21:04:20.588656, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'naclrpc_as_system' registered
[2018/04/12 21:04:20.588671, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'sasl-EXTERNAL' registered
[2018/04/12 21:04:20.588687, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'ntlmssp' registered
[2018/04/12 21:04:20.588702, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'ntlmssp_resume_ccache' registered
[2018/04/12 21:04:20.588718, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'http_basic' registered
[2018/04/12 21:04:20.588734, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'http_ntlm' registered
[2018/04/12 21:04:20.588749, 3] ../auth/gensec/gensec_start.c:977(gensec_register)
GENSEC backend 'http_negotiate' registered
[2018/04/12 21:04:20.588962, 3] ../source3/smbd/negprot.c:761(reply_negprot)
Selected protocol SMB 2.???
[2018/04/12 21:04:20.592542, 3] ../source3/smbd/smb2_negprot.c:291(smbd_smb2_request_process_negprot)
Selected protocol SMB2_10
[2018/04/12 21:04:20.597067, 3] ../auth/ntlmssp/ntlmssp_util.c:72(debug_ntlmssp_flags)
Got NTLMSSP neg_flags=0xe0888215
[2018/04/12 21:04:20.602288, 3] ../auth/ntlmssp/ntlmssp_server.c:552(ntlmssp_server_preauth)
Got user=[] domain=[] workstation=[] len1=0 len2=184
[2018/04/12 21:04:20.602366, 3] ../source3/param/loadparm.c:3869(lp_load_ex)
lp_load_ex: refreshing parameters
[2018/04/12 21:04:20.602468, 3] ../source3/param/loadparm.c:547(init_globals)
Initialising global parameters
[2018/04/12 21:04:20.602597, 3] ../source3/param/loadparm.c:2782(lp_do_section)
Processing section "[global]"
[2018/04/12 21:04:20.602732, 2] ../source3/param/loadparm.c:2461(lp_include)
Can't find include file /etc/samba/dhcp.conf
[2018/04/12 21:04:20.602866, 2] ../source3/param/loadparm.c:2799(lp_do_section)
Processing section "[disks]"
[2018/04/12 21:04:20.602954, 3] ../source3/param/loadparm.c:1617(lp_add_ipc)
adding IPC service
[2018/04/12 21:04:20.603000, 3] ../source3/auth/auth.c:189(auth_check_ntlm_password)
check_ntlm_password: Checking password for unmapped user []\[]@[] with the new password interface
[2018/04/12 21:04:20.603021, 3] ../source3/auth/auth.c:192(auth_check_ntlm_password)
check_ntlm_password: mapped user is: []\[]@[]
[2018/04/12 21:04:20.603090, 3] ../source3/auth/check_samsec.c:399(check_sam_security)
check_sam_security: Couldn't find user '' in passdb.
[2018/04/12 21:04:20.603113, 2] ../source3/auth/auth.c:332(auth_check_ntlm_password)
check_ntlm_password: Authentication for user [] -> [] FAILED with error NT_STATUS_NO_SUCH_USER, authoritative=1
[2018/04/12 21:04:20.603165, 2] ../auth/auth_log.c:760(log_authentication_event_human_readable)
Auth: [SMB2,(null)] user []\[] at [Thu, 12 Apr 2018 21:04:20.603148 UTC] with [NTLMv2] status [NT_STATUS_NO_SUCH_USER] workstation [] remote host [ipv4:192.1
68.1.86:39333] mapped to []\[]. local host [ipv4:192.168.1.31:445]
[2018/04/12 21:04:20.603208, 3] ../auth/auth_log.c:591(log_no_json)
log_no_json: JSON auth logs not available unless compiled with jansson
[2018/04/12 21:04:20.603230, 3] ../source3/auth/auth_util.c:1564(do_map_to_guest_server_info)
No such user [] - using guest account
[2018/04/12 21:04:20.609488, 0] ../libcli/smb/smb2_signing.c:171(smb2_signing_check_pdu)
Bad SMB2 signature for message
[2018/04/12 21:04:20.609586, 0] ../lib/util/util.c:514(dump_data)
[0000] 1C AA E5 28 AA DD 0D BC 74 E6 C7 3E AF 86 90 DC ...(.... t..>....
[2018/04/12 21:04:20.609639, 0] ../lib/util/util.c:514(dump_data)
[0000] 9C CD 04 26 42 07 27 BB 8E DB E5 F5 8C 9A EE D6 ...&B.'. ........
[2018/04/12 21:04:20.609683, 3] ../source3/smbd/smb2_server.c:3152(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_ACCESS_DENIED] || at ../source3/smbd/smb2_server.c:2459

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38427
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-04-16, 15:06 UTC

Do you get asked for the password when you don't enter it in the dialog? If not, the plugin may be getting an unexpected reply from the server.
Author of Total Commander
http://www.ghisler.com

Post Reply