This forum uses cookies. Click X button to hide this message. What is stored? / Privacy
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

No more sound played when saving file edited from FTP

 
Post new topic   Reply to topic    Total Commander Forum Index -> Total Commander (English) Printable version
View previous topic :: View next topic  
Author Message
Stv
Junior Member
Junior Member


Joined: 16 Apr 2015
Posts: 4

PostPosted: Thu Jul 05, 2018 7:55 pm    Post subject: No more sound played when saving file edited from FTP Reply with quote

I tend to edit files live on a server a lot by going to the file, hitting F4, editing the file, then saving the file and letting Total Commander automatically upload and overwrite the edited file (introduced in 8.50). In the previous version I had installed (9.10?), this would be accompanied by a sound being played if Total Commander was not the foreground application, equivalent to the 'Windows Background.wav' sound.

After updating to 9.20, this file is no longer played. I did go into the sound settings in Control Panel (aside: not a fan of Microsoft's desires that developers would use this - anything that takes you out of native config is jarring) and tried to setup both 'Total Commander > Copy/Move complete' and 'Transfer complete'.
Neither ends up playing the sound.

Copy/Move does affect file copy/move locally, which I promptly disabled again.
Transfer does affect copying a file from local to the FTP server, but definitely not when edit->save->auto-upload.

Did I miss a (new) setting somewhere? The change log doesn't seem to suggest anything new in this area.
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35974
Location: Switzerland

PostPosted: Fri Jul 06, 2018 7:19 am    Post subject: Reply with quote

Thanks for your report. I can confirm that there is no more beep in this case. It's not an intentional change. I will check what the problem is.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Stv
Junior Member
Junior Member


Joined: 16 Apr 2015
Posts: 4

PostPosted: Fri Jul 06, 2018 4:11 pm    Post subject: Reply with quote

Thank you for looking into this, appreciate it Smile
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35974
Location: Switzerland

PostPosted: Sun Jul 08, 2018 3:31 am    Post subject: Reply with quote

The problem is apparently that all dialog boxes now have the WS_POPUP style, and then GetActiveWindow returns the dialog even when the dialog is in the background. It seems to work when using GetForegroundWindow, though.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
iztoks
Junior Member
Junior Member


Joined: 11 Jul 2018
Posts: 2

PostPosted: Wed Jul 11, 2018 3:04 pm    Post subject: Missing beep after automatically re-upload changed files Reply with quote

Hello,

after TC upgrade from 9.1 to 9.2 there is no more beep sound after I save file and TC automatically re-uploads it to server. It's same on WIN 10 and WIN 7 computer. I'm using external editor to edit files and re-upload them via FTP/SFTP. I have tried custom sounds options without success. It was working fine until this upgrade.

Is this a bug or I'm missing something?

Thank you.
Back to top
View user's profile Send private message
tuska
Power Member
Power Member


Joined: 21 May 2007
Posts: 1130

PostPosted: Wed Jul 11, 2018 3:25 pm    Post subject: Reply with quote

Hi,
The forum search for "beep" brings the following post:
No more sound played when saving file edited from FTP
Back to top
View user's profile Send private message Send e-mail
Hacker
Moderator
Moderator


Joined: 06 Feb 2003
Posts: 10927
Location: Bratislava, Slovakia

PostPosted: Wed Jul 11, 2018 3:37 pm    Post subject: Reply with quote

Moderation:
Merged thread Missing beep after automatically re-upload changed files.

Hacker (Moderator)

_________________
Mal angenommen, du drückst Strg+F, wählst die FTP-Verbindung (mit gespeichertem Passwort), klickst aber nicht auf Verbinden, sondern fällst tot um.
Back to top
View user's profile Send private message Send e-mail
iztoks
Junior Member
Junior Member


Joined: 11 Jul 2018
Posts: 2

PostPosted: Thu Jul 12, 2018 8:48 am    Post subject: Reply with quote

ghisler(Author) wrote:
The problem is apparently that all dialog boxes now have the WS_POPUP style, and then GetActiveWindow returns the dialog even when the dialog is in the background. It seems to work when using GetForegroundWindow, though.


Is there anything we can do by ourselves to enable this feature? Any ETA for fix in future releases? Smile
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35974
Location: Switzerland

PostPosted: Fri Jul 13, 2018 3:54 am    Post subject: Reply with quote

No you can't, sorry. I'm working on a TC 9.21 now, but I'm still gathering bug reports.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> Total Commander (English) All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung | Politique de Confidentialité

Using phpBB © phpBB Group