Gehe zu in separater Suche in Archiven

German support forum

Moderators: Stefan2, white, sheep, Hacker

Post Reply
User avatar
Lefteous
Power Member
Power Member
Posts: 9433
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Gehe zu in separater Suche in Archiven

Post by *Lefteous » 2018-07-13, 10:05 UTC

Wenn ich mit der separaten Suche ein Archiv durchsuche und dann auf der gefundenen Datei "Gehe zu" ausführe, dann gelange auf die Archivdatei statt auf die markierte, gefundene Datei.

Ich bin mir gerade nicht sicher, ob das eine bekannte Einschränkung der separaten Suche war oder vielleicht ein Fehler.

TC 9.20, x64, Windows 7.

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3142
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Post by *Horst.Epp » 2018-07-13, 13:49 UTC

Confirmed
Bei mir wird nur in das Dir mit dem Archiv gesprungen,
aber nicht mal auf das Archive positioniert.
Getested mit zip und 7z Archiven.
In der normalen Suche geht das ohne Probleme.
Windows 10 Home x64 October 2018 Update, Version 1809 (OS Build 17763.194)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.21a x64 and x86, Everything 1.4.1.922 (x64)

User avatar
tuska
Power Member
Power Member
Posts: 1285
Joined: 2007-05-21, 12:17 UTC

Post by *tuska » 2018-07-13, 14:41 UTC

Horst.Epp wrote:… Bei mir wird nur in das Dir mit dem Archiv gesprungen,
aber nicht mal auf das Archive positioniert.
Getested mit zip und 7z Archiven. ...
Nach ALT+Umschalt+F7 wird im Suchergebnis bei "gehe zu" bei mir der Cursor schon auf dem Archiv positioniert,
aber ebenfalls nicht auf die gefundene Archivdatei.
Gruß,
Karl

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36557
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) » 2018-07-15, 07:15 UTC

Danke, ich kann das Problem nachvollziehen.
Author of Total Commander
http://www.ghisler.com

User avatar
tuska
Power Member
Power Member
Posts: 1285
Joined: 2007-05-21, 12:17 UTC

Re: Gehe zu in separater Suche in Archiven

Post by *tuska » 2018-08-15, 13:15 UTC

In der 32bit-Version (TC 9.21 final) kommt noch folgende Meldung:
7-zip library is not found.
Download 7-Zip
http://www.7-zip.org/

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3142
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: Gehe zu in separater Suche in Archiven

Post by *Horst.Epp » 2018-08-15, 13:26 UTC

Bei mir nicht.
Bei welcher Funktion ?
Windows 10 Home x64 October 2018 Update, Version 1809 (OS Build 17763.194)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.21a x64 and x86, Everything 1.4.1.922 (x64)

User avatar
tuska
Power Member
Power Member
Posts: 1285
Joined: 2007-05-21, 12:17 UTC

Re: Gehe zu in separater Suche in Archiven

Post by *tuska » 2018-08-15, 13:41 UTC

- D:\Tcqsp.zip
- ALT-F7 bzw. ALT-Umschalt-F7
- Suchen nach: TCqsp.chm
- Suchen in: D:\
- [x] Archive durchsuchen (alle außer UC2)
- [x] 'Everything'
- Unterverzeichnisse durchsuchen: Nur aktuelles Verzeichnis
- Button "Suche starten" --> "7-zip library is not found. …"
- findet: D:\Tcqsp.zip/TCqsp\TCqsp.chm
- Button "gehe zu"

Ergebnis:
Cursor auf Datei TCqsp.chm (Pfadzeile: D:\Tcqsp.zip/TCqsp\*.*)

In 64bit-Version funktioniert es.

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3142
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: Gehe zu in separater Suche in Archiven

Post by *Horst.Epp » 2018-08-15, 14:33 UTC

tuska wrote:
2018-08-15, 13:41 UTC
- D:\Tcqsp.zip
- ALT-F7 bzw. ALT-Umschalt-F7
- Suchen nach: TCqsp.chm
- Suchen in: D:\
- [x] Archive durchsuchen (alle außer UC2)
- [x] 'Everything'
- Unterverzeichnisse durchsuchen: Nur aktuelles Verzeichnis
- Button "Suche starten" --> "7-zip library is not found. …"
- findet: D:\Tcqsp.zip/TCqsp\TCqsp.chm
- Button "gehe zu"

Ergebnis:
Cursor auf Datei TCqsp.chm (Pfadzeile: D:\Tcqsp.zip/TCqsp\*.*)

In 64bit-Version funktioniert es.
Ich habe das mit einem 7z und einem zip Archive getested
und keine Probleme beim Suchen nach einer Datei im Archiv und dem Gehe zu Button.
Getested mit und ohne Total7zip Plugin und mit dem x86 und x64 TC
Windows 10 Home x64 October 2018 Update, Version 1809 (OS Build 17763.194)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.21a x64 and x86, Everything 1.4.1.922 (x64)

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36557
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Gehe zu in separater Suche in Archiven

Post by *ghisler(Author) » 2018-08-15, 15:57 UTC

Bei mir tritt es auch nicht auf - die Meldung scheint von Total7zip zu kommen. Ich würde mal versuchen, die neueste Version von Total7zip (erneut) zu installieren.
Author of Total Commander
http://www.ghisler.com

User avatar
tuska
Power Member
Power Member
Posts: 1285
Joined: 2007-05-21, 12:17 UTC

Re: Gehe zu in separater Suche in Archiven

Post by *tuska » 2018-08-15, 16:52 UTC

2Horst.Epp
Danke, das Du das nochmals so gründlich getestet hast.

2ghisler(Author)
Danke für die Unterstützung bei meinem Problem.

Ich habe jetzt
- das Total7zip Plugin neu installiert
- eine alte 7-Zip 9.38 (x64 edition) und die aktuelle 7-zip 18.05 (x64) Version gelöscht
- die aktuelle 7-zip 18.05 (x64) Version neu installiert
- die aktuellen Dateien von C:\Program Files\7-Zip\ id Verz. %COMMANDER_PATH%\Plugins\wcx\Total7zip\ überspielt

So sehen die Einstellungen aus:

wincmd.ini [PackerPlugins]
7z=735,%COMMANDER_PATH%\Plugins\wcx\Total7zip\Total7zip.wcx
ISO=735,%COMMANDER_PATH%\Plugins\wcx\Total7zip\Total7zip.wcx64

Konfigurieren - Plugins - Packer-Plugins (.WCX)
735,%COMMANDER_PATH%\Plugins\wcx\Total7zip\Total7zip.wcx
735,%COMMANDER_PATH%\Plugins\wcx\Total7zip\Total7zip.wcx64

Leider nach wie vor in TC 9.21 32bit die Meldung "7-zip library is not found. ...".
Ich habe leider auch keinen Plan, wie ich das Problem noch lösen könnte und werde es vorläufig dabei belassen,
da ich die 64bit Versionen verwende (werde ggf. zu diesem Thema später ein eigenes Thema aufmachen).

Das vom Threadstarter Lefteous aufgezeigte Problem betrachte ich jetzt ebenfalls als gelöst und somit erledigt.

User avatar
Dalai
Power Member
Power Member
Posts: 6319
Joined: 2005-01-28, 22:17 UTC
Location: Meiningen (Südthüringen)

Re: Gehe zu in separater Suche in Archiven

Post by *Dalai » 2018-08-15, 17:47 UTC

2tuska
Die Meldung stammt definitv vom Total7zip-Plugin. Schau mal, ob die Total7zip.xml passt. Beachte außerdem, dass Total7zip x64 erwartet, dass die Dateien in %plugindir%\64 liegen, die 32 bit-Version in %plugindir%.

Grüße
Dalai
#101164 Personal licence
Athlon X4 880K, 16 GiB RAM, Gigabyte F2A88X-D3HP, Win7 x64

Plugins: Services2, Startups

User avatar
tuska
Power Member
Power Member
Posts: 1285
Joined: 2007-05-21, 12:17 UTC

Re: Gehe zu in separater Suche in Archiven

Post by *tuska » 2018-08-15, 18:22 UTC

2Dalai
Besten Dank für Deine Hinweise - jetzt funktioniert es auch bei mir!
Mein Fehler war, daß ich nur die 64bit-Variante installiert hatte und nicht zusätzlich auch noch die 32bit-Variante.

Die 32bit-Variante habe ich jetzt unter C:\Program Files (x86)\7-Zip\ installiert und die aktuellen Dateien
nach %COMMANDER_PATH%\Plugins\wcx\Total7zip\ (drüber-)kopiert.

Ich habe noch von Datei Total7zip.xml eine Kopie gemacht und auf Total7zip_ORIGINAL.xml umbenannt.
Danach habe ich folgende Einträge in der Total7zip.xml getätigt:

%COMMANDER_PATH%\Plugins\wcx\Total7zip\Total7zip.xml

Code: Select all

<path path_7z_dll="%COMMANDER_PATH%\Plugins\wcx\Total7zip\7z.dll" path_7zG_exe="%COMMANDER_PATH%\Plugins\wcx\Total7zip\7zG.exe" />
%COMMANDER_PATH%\Plugins\wcx\Total7zip\64\Total7zip.xml

Code: Select all

<path path_7z_dll="%COMMANDER_PATH%\Plugins\wcx\Total7zip\64\7z.dll" path_7zG_exe="%COMMANDER_PATH%\Plugins\wcx\Total7zip\64\7zG.exe" />
Danke Dir und auch nochmals an Herrn Ghisler für die Unterstützung!

User avatar
Lefteous
Power Member
Power Member
Posts: 9433
Joined: 2003-02-09, 01:18 UTC
Location: Germany
Contact:

Re: Gehe zu in separater Suche in Archiven

Post by *Lefteous » 2018-08-16, 07:51 UTC

history.txt wrote:15.08.18 Fixed: Search in background: click on "Go to file" not going to files inside archives (64)
In TC 9.21 funktioniert es jetzt einwandfrei. Danke sehr :-)

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 36557
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Gehe zu in separater Suche in Archiven

Post by *ghisler(Author) » 2018-08-16, 09:41 UTC

Leider hat dieser Bugfix auch den Fehler mit "Everything" ausgelöst:
https://www.ghisler.ch/board/viewtopic.php?f=28&t=50785
Author of Total Commander
http://www.ghisler.com

Post Reply