Directory tree and Everything.

English support forum

Moderators: sheep, Hacker, Stefan2, white

vdijken
Junior Member
Junior Member
Posts: 80
Joined: 2016-07-30, 14:07 UTC
Location: The Netherlands

Directory tree and Everything.

Post by *vdijken » 2019-10-17, 14:16 UTC

When you open the first time the directory tree with Alt-F10 the directory tree appears as usual. When you tick "Everything" the window becomes empty. Pressing F2 shows no activity, but sometimes the file TreeinfoC.wc is gone.

User avatar
tuska
Power Member
Power Member
Posts: 1758
Joined: 2007-05-21, 12:17 UTC

Re: Directory tree and Everything.

Post by *tuska » 2019-10-17, 14:41 UTC

Maybe this could be related to the "Everything Service" or whether you have indexed this NTFS-drive or folder in Everything.

Does the "Everything Service" work for you?
TaskManager: CTRL+SHIFT+ESC > Services Tab > Everything ... Status: is running?
(If you are using Everything as a user, then the Everything service should have the status "is running").

Everything Options > Indexes > NTFS > Settings for drive, e.g. Settings for Local Disk (C:) > ☑ Include in database
OR
Everything Options > Indexes > Folders

EDIT:
Do you have "The external index tool 'Everything'" in use at all?

vdijken
Junior Member
Junior Member
Posts: 80
Joined: 2016-07-30, 14:07 UTC
Location: The Netherlands

Re: Directory tree and Everything.

Post by *vdijken » 2019-10-17, 14:57 UTC

Everything with ALt-f7 works fine to find files in TC; and the services is active. So that is not the problem. And also not a misssing text in Dutch is causing it; I switched to English and the problem stays.

User avatar
tuska
Power Member
Power Member
Posts: 1758
Joined: 2007-05-21, 12:17 UTC

Re: Directory tree and Everything.

Post by *tuska » 2019-10-17, 15:00 UTC

OK, then I don't have an idea right now.

User avatar
tuska
Power Member
Power Member
Posts: 1758
Joined: 2007-05-21, 12:17 UTC

Re: Directory tree and Everything.

Post by *tuska » 2019-10-17, 15:05 UTC

Maybe you should let the author know if the problem occurs
- in the 32 bit as well as in the 64 bit version
- with a TC_clean.ini

Regards,
Karl

User avatar
Horst.Epp
Power Member
Power Member
Posts: 3474
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Re: Directory tree and Everything.

Post by *Horst.Epp » 2019-10-17, 15:37 UTC

vdijken wrote:
2019-10-17, 14:16 UTC
When you open the first time the directory tree with Alt-F10 the directory tree appears as usual. When you tick "Everything" the window becomes empty. Pressing F2 shows no activity, but sometimes the file TreeinfoC.wc is gone.
Not confirmed for TC 9.50b1 x86 and x64.
Everything running as service and in the background as usual.
Windows 10 Home x64 November 2019 Update, Version 1909 (OS Build 18363.476)
Intel(R) Core(TM) i7-4770 CPU @ 3.40GH, 16GB RAM
TC 9.50ß8 x64 / x86, Everything 1.4.1.959 (x64)

vdijken
Junior Member
Junior Member
Posts: 80
Joined: 2016-07-30, 14:07 UTC
Location: The Netherlands

Re: Directory tree and Everything.

Post by *vdijken » 2019-10-17, 15:57 UTC

I use X64. And I am not entitled to enter the Test Forum; so how do I find a clean TC_clean.ini? I also looked into the Windows logging, but nothing pops up. When I start Everything as an executable I see the directories in the Everything database. I started with an empty wincmd.ini and the error stays.
And in wincmd.ini is a line EverythingForTree = 1; so the tick works.

User avatar
tuska
Power Member
Power Member
Posts: 1758
Joined: 2007-05-21, 12:17 UTC

Re: Directory tree and Everything.

Post by *tuska » 2019-10-17, 18:54 UTC

vdijken wrote:...I am not entitled to enter the Test Forum...
Registration in the test forum is not required.
The link above should show you the content.

If you still want to log in to the test forum you can use the same user and password as for this forum.
vdijken wrote:...how do I find a clean TC_clean.ini...
...I started with an empty wincmd.ini...
An "empty" wincmd.ini means the same as a TC_clean.ini, fresh .ini, fresh wincmd.ini.

The problem you have is inexplicable to me.

Btw, what is your Operating System?


Windows 10 Pro (x64) Version 1903 (OS build 18362.418)
Intel(R) Core(TM) i7-4770 CPU @ 3.4OGHz, 16 GB RAM
TC 9.50ß1 x64/x86 | Everything - Version 1.4.1.949 (x64)
☑ 'Everything' | How to use TC <=> Everything

vdijken
Junior Member
Junior Member
Posts: 80
Joined: 2016-07-30, 14:07 UTC
Location: The Netherlands

Re: Directory tree and Everything.

Post by *vdijken » 2019-10-17, 21:40 UTC

Latest Windows 10 Pro. Version 1903 build 18362,418

User avatar
tuska
Power Member
Power Member
Posts: 1758
Joined: 2007-05-21, 12:17 UTC

Re: Directory tree and Everything.

Post by *tuska » 2019-10-18, 09:58 UTC

Now it is currently 2:1 :)
2x it works for users with the same software
1x it doesn't work for you

What does it look like in your wincmd.ini? (Location: Menu "Help" - "About Total Commander...")
With me regarding "Everything" there are e.g. the following entries:

Code: Select all

UseEverything=1
EverythingForTree=1
-----------
Btw, could not find: EverythingForTree= in TC Help.
-----------
In this context, I have made another observation:
1. ALT+F10
2. check 'Everything
3. type in search word
4. uncheck 'Everything' [or check in front of another search query --> see point 6. ...]
5. button "F2 re-scan tree" can still be pressed
6. the last search word is displayed, it can no longer be deleted and a new search query is no longer possible
7. Press the "OK" button to enter the TC window, then press ALT+F10 to enter a new search query.

At this point I would like to suggest the following:
Ctrl + Y deletes the input field [or does anyone else know how to delete the input except with the backspace key <-|]?

User avatar
petermad
Power Member
Power Member
Posts: 8973
Joined: 2003-02-05, 20:24 UTC
Location: Valsted, Denmark
Contact:

Re: Directory tree and Everything.

Post by *petermad » 2019-10-18, 13:14 UTC

Btw, could not find: EverythingForTree= in TC Help.
Already reported: viewtopic.php?p=360305#p360305 ;-)
License #524 (1994)
Danish Total Commander Translator
TC 9.5b8 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 (1909) 64bit, 'Everything' 1.4.1.935 (x64)
TC 3.0b12 on Android 6.0
Get: Extended Total Commander Menus | PHSM-Calendar

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38408
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Directory tree and Everything.

Post by *ghisler(Author) » 2019-10-18, 16:04 UTC

You are right, there are some problems when Everything has to be loaded - it takes a lot of time until it gets ready.
I will show the progress dialog with cancel button when 'Everything' reports that it's busy, as I do now in the search dialog.
Author of Total Commander
http://www.ghisler.com

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 38408
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Directory tree and Everything.

Post by *ghisler(Author) » 2019-10-22, 15:41 UTC

Please try with beta 2: It will do the same as the search dialog when everything is not ready: It will display a progress dialog, which the user can cancel.
Author of Total Commander
http://www.ghisler.com

User avatar
tuska
Power Member
Power Member
Posts: 1758
Joined: 2007-05-21, 12:17 UTC

Re: Directory tree and Everything.

Post by *tuska » 2019-10-22, 18:33 UTC

Code: Select all

[Configuration]
TreeFileLocation=%COMMANDER_PATH%\treeinfo%D%.wc
D:\Daten\Programme\TotalCommander\TCD_USB-Stick\TC32-64USB = %COMMANDER_PATH%
D:\Daten\Programme\TotalCommander\TCD_USB-Stick\TC32-64USB\treeinfoD.wc,treeinfoG.wc,treeinfoI.wc,treeinfoJ.wc --> available!

I am missing (even after F2) only the treeinfoC.wc.

These observations of vdijken I cannot quite understand:
- When you tick "Everything" the window becomes empty
- Pressing F2 shows no activity

If Everything is running (indexed), then there is no significant activity here, because everything is up to date.
The directory tree is only faded out briefly after "F2 re-scan tree" and faded in again for me immediately - C: storage size: 105 GB.

Retested with TC 9.50b2 x64 & x86.
Windows 10 Pro (x64) Version 1903 (OS build 18362.418)
Intel(R) Core(TM) i7-4770 CPU @ 3.4OGHz, 16 GB RAM

User avatar
fenix_productions
Power Member
Power Member
Posts: 1956
Joined: 2005-08-07, 13:23 UTC
Location: Poland
Contact:

Re: Directory tree and Everything.

Post by *fenix_productions » 2019-10-22, 19:09 UTC

I had same trouble:
I tick "Everything" checkbox -> DirectoryTree becomes empty.

…but I have realised that TC was running as admin but Everything did not.
Once Everything is set as admin all works.
"When we created the poke, we thought it would be cool to have a feature without any specific purpose." Facebook...

#128099

Post Reply