Cyrillic symbols fonts not showing properly in archives

Support for Android version of Total Commander

Moderators: sheep, Hacker, Stefan2, white

Post Reply
sppmaster
Junior Member
Junior Member
Posts: 3
Joined: 2019-11-13, 10:58 UTC

Cyrillic symbols fonts not showing properly in archives

Post by *sppmaster »

Cyrillic symbols fonts not showing properly in archives.
I have this situation on Android 9.
Image: https://uploads.tapatalk-cdn.com/20191112/91509b82ce661206f3efe77fd8e035fb.jpg

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39728
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Cyrillic symbols fonts not showing properly in archives

Post by *ghisler(Author) »

ZIP archives do not store which encoding is used, except when configuring the sender to use UTF-8.

TC for Android uses the current language settings to determine the encoding. Try changing your phone language to Russian, Serbian or other language using Cyrillic symbols.
Author of Total Commander
http://www.ghisler.com

sppmaster
Junior Member
Junior Member
Posts: 3
Joined: 2019-11-13, 10:58 UTC

Re: Cyrillic symbols fonts not showing properly in archives

Post by *sppmaster »

I see. I don't want to change the Android system language to other one different from English. If there is no way to implement an option in the TC configuration to choose the encoding, I will continue to use it this way. Thanks.

User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39728
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Cyrillic symbols fonts not showing properly in archives

Post by *ghisler(Author) »

I have recently added this to TC 9.50 beta for Windows, so maybe i will add it to Android too.
Author of Total Commander
http://www.ghisler.com

sppmaster
Junior Member
Junior Member
Posts: 3
Joined: 2019-11-13, 10:58 UTC

Re: Cyrillic symbols fonts not showing properly in archives

Post by *sppmaster »

Thanks. It will be very useful.

Post Reply