[WFX] Android ADB 7.3

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: Hacker, Stefan2, white, sheep

Post Reply
Schumi
New Member
New Member
Posts: 1
Joined: 2016-12-07, 15:45 UTC

Post by *Schumi » 2016-12-07, 15:46 UTC

Yes, needed plugin for unix.

Slofje
Junior Member
Junior Member
Posts: 15
Joined: 2006-08-01, 18:27 UTC
Location: Nederland

Re: [WFX] Android ADB 7.3

Post by *Slofje » 2016-12-12, 23:36 UTC

EDIT: SORRY, DISCOVERED VERSION 7.9. PROBLEM SOLVED!

Tonight Android 6.0.1 on my LG G5 was updated to Android 7.0.
Now Android ADB 7.6 no longer works correctly.
I did some research: It appears that the output of the LS command has been changed. It looks like there is a new second column inserted.

Is this a known issue?

Here is a piece of my debug log:

2016-12-13 00:30:08 [09A8] Connecting to ADB server...
2016-12-13 00:30:08 [09A8] Connected
2016-12-13 00:30:08 [09A8] ADB Write: host:devices
2016-12-13 00:30:08 [09A8] ADB Read: LGH8507c8ca2e5 device
2016-12-13 00:30:14 [09A8] Connecting to ADB server...
2016-12-13 00:30:14 [09A8] Connected
2016-12-13 00:30:14 [09A8] ADB Write: host:transport:LGH8507c8ca2e5
2016-12-13 00:30:14 [09A8] ADB Read: OKAY
2016-12-13 00:30:14 [09A8] ADB Write: shell:ls -la "/"
2016-12-13 00:30:14 [09A8] ADB Read: OKAY
2016-12-13 00:30:14 [09A8] ADB Read Data: total 7568
drwxrwxrwt 26 root root 1760 2016-06-13 02:39 .
drwxrwxrwt 26 root root 1760 2016-06-13 02:39 ..
drwxr-xr-x 4 root root 4096 2016-01-01 01:31 OP
dr-xr-xr-x 119 root root 0 2016-06-13 02:39 acct
drwxrwx--x 2 system system 40 2016-06-13 02:39 bt_firmware
drwxrwx--- 8 system cache 4096 2016-06-13 02:39 cache
lrwxrwxrwx 1 root root 13 1970-01-01 01:00 charger -> /sbin/healthd
drwxr-xr-x 2 root root 0 2016-06-13 02:39 config
drwxr-xr-x 8 root root 4096 2016-06-13 02:38 cust
lrwxrwxrwx 1 root root 17 1970-01-01 01:00 d -> /sys/kernel/debug
drwxrwx--x 53 system system 4096 2016-12-12 22:36 data
-rw-r--r-- 1 root root 991 1970-01-01 01:00 default.prop
drwxr-xr-x 17 root root 4260 2016-12-12 22:36 dev
drwxrwx--x 2 media media 40 2016-06-13 02:39 dsp
lrwxrwxrwx 1 root root 11 1970-01-01 01:00 etc -> /system/etc
drwxr-xr-x 2 root root 80 1970-01-01 01:00 ffu
-rw-r--r-- 1 root root 368916 1970-01-01 01:00 file_contexts.bin
dr-xr-x--- 4 system system 16384 1970-01-01 01:00 firmware
-rw-r----- 1 root root 634 1970-01-01 01:00 fstab.fota
-rw-r----- 1 root root 1307 1970-01-01 01:00 fstab.h1
-rwxr-x--- 1 root root 1389032 1970-01-01 01:00 init
-rwxr-x--- 1 root root 3295 1970-01-01 01:00 init.class_main.sh
-rwxr-x--- 1 root root 1032 1970-01-01 01:00 init.environ.rc
-rwxr-x--- 1 root root 3471 1970-01-01 01:00 init.h1.power.rc
-rwxr-x--- 1 root root 286 1970-01-01 01:00 init.h1.rc
-rwxr-x--- 1 root root 18878 1970-01-01 01:00 init.h1_core.rc
-rwxr-x--- 1 root root 1543 1970-01-01 01:00 init.h1_product.rc
..
..
.

Slofje
Junior Member
Junior Member
Posts: 15
Joined: 2006-08-01, 18:27 UTC
Location: Nederland

Re: [WFX] Android ADB 7.3

Post by *Slofje » 2016-12-16, 19:15 UTC

After my previous mistake, I hesitate to report another problem:

I cannot delete or rename a file on the external SD card of my Android 7.0 phone, using Android ADB 7.9
Creating and updating files works fine.
I CAN rename and delete the file with the Android version of Total Commander 2.72 on my phone.

I'm pretty sure this problem didn't exist with Android 6.0.1 and Android ADB 7.6

Here are the (I think) relevant parts of my debug.log.
First I successfully copied the file "WindowsLog.TXT" to the Music directory on the external SD-card. Then I unsuccessfully tried to rename it to "Windows-Log.TXT"


2016-12-16 19:41:33 [0EE0] Connecting to ADB server...
2016-12-16 19:41:33 [0EE0] Connected
2016-12-16 19:41:33 [0EE0] ADB Write: host:transport:LGH8507c8ca2e5
2016-12-16 19:41:33 [0EE0] ADB Read: OKAY
2016-12-16 19:41:33 [0EE0] ADB Write: sync:
2016-12-16 19:41:33 [0EE0] ADB Read: OKAY
2016-12-16 19:41:33 [0EE0] ADB Write: STAT' /storage/493B-ABD9/Music/WindowsLog.TXT
2016-12-16 19:41:33 [0EE0] ADB Read: STAT
2016-12-16 19:41:33 [0EE0] ADB STAT: "/storage/493B-ABD9/Music/WindowsLog.TXT" does not exist!
2016-12-16 19:41:33 [0EE0] ADB Write: SEND- /storage/493B-ABD9/Music/WindowsLog.TXT,33206
2016-12-16 19:41:33 [0EE0] ADB Write: DONE\1MX
2016-12-16 19:41:33 [0EE0] ADB Read: OKAY
2016-12-16 19:41:33 [2278] Connecting to ADB server...
2016-12-16 19:41:33 [2278] Connected


2016-12-16 19:41:45 [2278] Connecting to ADB server...
2016-12-16 19:41:45 [2278] Connected
2016-12-16 19:41:45 [2278] ADB Write: host:transport:LGH8507c8ca2e5
2016-12-16 19:41:45 [2278] ADB Read: OKAY
2016-12-16 19:41:45 [2278] ADB Write: shell:busybox mv -f "/storage/493B-ABD9/Music/WindowsLog.TXT" "/storage/493B-ABD9/Music/Windows-Log.TXT"
2016-12-16 19:41:45 [2278] ADB Read: OKAY
2016-12-16 19:41:45 [2278] ADB Read Data: /system/bin/sh: busybox: not found
2016-12-16 19:41:45 [2278] Connecting to ADB server...
2016-12-16 19:41:45 [2278] Connected
2016-12-16 19:41:45 [2278] ADB Write: host:transport:LGH8507c8ca2e5
2016-12-16 19:41:45 [2278] ADB Read: OKAY
2016-12-16 19:41:45 [2278] ADB Write: shell:mv "/storage/493B-ABD9/Music/WindowsLog.TXT" "/storage/493B-ABD9/Music/Windows-Log.TXT"
2016-12-16 19:41:45 [2278] ADB Read: OKAY
2016-12-16 19:41:45 [2278] ADB Read Data: mv: bad '/storage/493B-ABD9/Music/WindowsLog.TXT': Permission denied
2016-12-16 19:41:45 [2278] Connecting to ADB server...
2016-12-16 19:41:45 [2278] Connected

rsanjuan1987
New Member
New Member
Posts: 1
Joined: 2017-01-13, 21:45 UTC

Remote temp path

Post by *rsanjuan1987 » 2017-01-13, 22:12 UTC

Please add the option to set the remote path of tmp why?
Why when you install an application and the size of this does not fit 2 times then just upload it and not install saying that you do not have space
However if you upload it for example "/sdcard/.tcadb/tmp/" and then it is installed from there then it fits.
by the way did you change the icon cache folder path as I asked?
regards

Suncatcher
Junior Member
Junior Member
Posts: 14
Joined: 2013-12-30, 10:59 UTC

Shortcuts

Post by *Suncatcher » 2017-01-14, 11:58 UTC

Does anybody know hot to create shortcuts to files/folders with this plugin?
It is in plugin features but there is not guide.

cmlx
Junior Member
Junior Member
Posts: 19
Joined: 2011-01-31, 02:42 UTC

Post by *cmlx » 2017-02-05, 06:37 UTC

The latest 8.0 version cannot work on TC win32.

seb-
Senior Member
Senior Member
Posts: 272
Joined: 2011-11-15, 06:14 UTC
Location: DE\BN

Post by *seb- » 2017-02-06, 11:32 UTC

cmlx wrote:The latest 8.0 version cannot work on TC win32.
Confirmed here...

i was just about to complain that i get the following message

Code: Select all

Error loading plugin file!

The plugin probably needs some DLLs missing on your system.
After / while installing the plugin in 32bit TC.

Then i tried the 64bit one and i can install and use the plugin....

Is there some mirror to get the old version?


thanks br
seb

Hurdet
Senior Member
Senior Member
Posts: 424
Joined: 2003-05-10, 18:02 UTC

Post by *Hurdet » 2017-02-06, 16:03 UTC

seb- wrote:
cmlx wrote:The latest 8.0 version cannot work on TC win32.
Where it is 8.0 version?

iana
Senior Member
Senior Member
Posts: 342
Joined: 2010-07-27, 22:00 UTC

Post by *iana » 2017-02-07, 00:03 UTC

Where it is 8.0 version?
at the developers home page
http://www.uniqtec.eu/applications/android-adb.html
version 8 is a strange release with a 32bit only windows build and 4 64bit Linux builds (there are 5 wfx files in the Linux x64 zip one being an install wfx)

edit there is a 64bit plugin in the windows zip

iana
Senior Member
Senior Member
Posts: 342
Joined: 2010-07-27, 22:00 UTC

Post by *iana » 2017-02-07, 01:04 UTC

I can confirm 32bit version 8 does not work, looks like a bad compile
the x64 version is still at 7.9 and works, unfortunately v7.9 which worked was not uploaded at totalcmd.net and there are no older releases hosted at the authors site, if you have 7.9 make a copy of the 32bit dll as totalcmd.net has 7.6

algol
Senior Member
Senior Member
Posts: 418
Joined: 2007-07-31, 14:45 UTC

Post by *algol » 2017-03-13, 16:10 UTC

Hello there,

after about 1 month since the last post I'm just wondering if there is a final 8.0-version available in the meantime, that would fix the aforementioned issues in thi thread.

Also, after test-installing v.8.0 on my system, it still says "ANDROID ADB 7.9" in the Options-dialog within TC9.0a/Network/ADB.

greetings
algol

DuckDaffy
Junior Member
Junior Member
Posts: 12
Joined: 2016-06-10, 14:26 UTC

BUG? Screenshot download fails

Post by *DuckDaffy » 2017-03-17, 13:15 UTC

When I tried to download screendshot it do something, bar running, but then I got dialog "Error downloading file!".

Phone: Elephone M2, Android 5.1
ADB WFX: lastest v8.0 from web (downloaded today)
ADB exe: tried two, packed in ZIP and newest v25.0.3 from Google: https://developer.android.com/studio/releases/platform-tools.html
PC: Win10 x64

I think it was work with ADB WFX v7.3 or 7.6, I will try it at another PC later to confirm.

DuckDaffy
Junior Member
Junior Member
Posts: 12
Joined: 2016-06-10, 14:26 UTC

Issue? Alt+Shift+Enter takes a lot of time, No signalisation

Post by *DuckDaffy » 2017-03-17, 13:33 UTC

I often use Alt+Shift+Enter to verify directory sizes and delete unwanted data, but with ADB WFX it is quite unusable.

Simple Music directory with 24 subdirectories takes ~6 seconds.

Huge directory of Evernote offline files with ~3500 subdirectories after 20 minutes still never ends. :(

Hope some caching or another speed up can be implement. :)

In addition, no signalisation of ongoing process is also problem.
No mouse cursor with "hourglass", nor classsic "?" on line instead of "<DIR>". It always looks like do nothing and it is very easy to break up by some action in TC and get lost all current DIR size counting.

Maybe there is some problem with multithreading because sometime line still show "<DIR>", but after SPACE pressed it show some number.

BTW: Alt+B do nothing. :(

Hope it helps and I'm ready for help and testing if you need something.

booroondook
New Member
New Member
Posts: 1
Joined: 2017-03-21, 14:08 UTC
Location: Russia

Post by *booroondook » 2017-03-21, 14:16 UTC

Last versions of the plugin (tested on 7.9 and 8.0) incorrectly copy screenshots from Android device. The are two variants and both are incorrect:
1) Cannot copy file from ".screenshot" folder (copying aborted with error).
2) The png-file was copied has incorrect internal structure.
P.S. version 7.6 works normally.

xsoft
New Member
New Member
Posts: 1
Joined: 2017-05-03, 11:17 UTC

Post by *xsoft » 2017-05-03, 11:21 UTC

Hi,
version 8.0 is missing all icons (at connect/option, and also at dir. listing).
Previous version have those.

Also option menu is missing all graphics.

(ive tried to reinstall, and delete and install)

Post Reply