[WFX] Android ADB 7.3

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: white, sheep, Hacker, Stefan2

Post Reply
damjang
Senior Member
Senior Member
Posts: 205
Joined: 2003-10-09, 15:58 UTC
Contact:

Post by *damjang » 2017-05-28, 21:57 UTC

For me the last 8.0 plugin don't work, nor the previous 7.6 with my new samsung galaxy s7 with nougat. Is there someone that can share the v7.9 to try with?

iMiKE
Junior Member
Junior Member
Posts: 2
Joined: 2013-04-04, 02:46 UTC
Location: Novosibirsk

Post by *iMiKE » 2017-07-20, 12:45 UTC

Hello!
Any chances to get this plugin to macOS for DoubleCommander?

TW
Senior Member
Senior Member
Posts: 330
Joined: 2005-01-19, 13:35 UTC

Post by *TW » 2017-07-30, 22:22 UTC

this doesn't work at all with my samsung S4 mini, simply nothing happens when i try to connect.

chances are high i'm doing something wrong, but then there is no real FAQ on the homepage, simply all the features are mentioned, but not how to use it really.
licenced and happy TC user since 1994 (#11xx)

User avatar
nsp
Power Member
Power Member
Posts: 1190
Joined: 2005-12-04, 08:39 UTC
Location: Lyon (FRANCE)
Contact:

Post by *nsp » 2017-08-01, 09:03 UTC

TW wrote:this doesn't work at all with my samsung S4 mini, simply nothing happens when i try to connect.

chances are high i'm doing something wrong, but then there is no real FAQ on the homepage, simply all the features are mentioned, but not how to use it really.
You should first try to check
1) if your phone have USB debug activated on developer settings and is connected with usb cable to your PC.
2) on the PC, check the adb used version detect your phone and driver are well installed.
3) if you validated the access on your phone for the current PC. You can invalidate all adb access and wait for new request.

sitycarbon
Junior Member
Junior Member
Posts: 3
Joined: 2017-08-02, 14:27 UTC

Post by *sitycarbon » 2017-08-02, 14:29 UTC

I'm using a Galaxy S8 and have a strange issue.

When copying small files to /system less than 20MB. they fail. Larger files seem to copy OK.

No problem copying the small files to /sdcard.

02/08/2017 22:32:37: FS:Copy(Error: Failed): c:\temp\lxy.log -> \\\ADB\ce041714801bc72504\system\priv-app\lxy.log

02/08/2017 22:33:04: FS:Copy: c:\temp\bios.bin -> \\\ADB\ce041714801bc72504\system\priv-app\bios.bin

kulmegil
Junior Member
Junior Member
Posts: 17
Joined: 2006-05-27, 10:36 UTC

Post by *kulmegil » 2017-08-17, 18:44 UTC

Just a note - there is v8.2 on author's website.

Works noticeably better for me, but still fails to modify /system or /data.
But can read them again and I had issues on 8.0.

Ponozka
New Member
New Member
Posts: 1
Joined: 2017-09-07, 12:39 UTC

Post by *Ponozka » 2017-09-07, 13:21 UTC

kulmegil wrote:Just a note - there is v8.2 ...

Works noticeably better for me, but still fails to modify /system or /data.
But can read them again and I had issues on 8.0.
1) you can't change the /system folder because it is mounted as read only.

2) you can change the /data folder only if you have the permissions,
e.g. you can add a subfolder in /data, but you can't read/write files in the application data area.

But a real bug is, that the plugin don't process symbolic links,
e.g./mnt/sdcard -> /storage/sdcard0 is recognized as a file.
Last edited by Ponozka on 2017-09-07, 13:31 UTC, edited 2 times in total.

flo
Junior Member
Junior Member
Posts: 48
Joined: 2007-01-21, 14:57 UTC

Post by *flo » 2017-09-07, 13:24 UTC

Since 8.x version no icons appear in options for this plugin (.apps, .backup, .bugreport,..). With 7.4 i dont't have this problem

anybody else has this problem?

TW
Senior Member
Senior Member
Posts: 330
Joined: 2005-01-19, 13:35 UTC

Post by *TW » 2017-09-09, 20:44 UTC

nsp wrote:
TW wrote:this doesn't work at all with my samsung S4 mini, simply nothing happens when i try to connect.

chances are high i'm doing something wrong, but then there is no real FAQ on the homepage, simply all the features are mentioned, but not how to use it really.
You should first try to check
1) if your phone have USB debug activated on developer settings and is connected with usb cable to your PC.
2) on the PC, check the adb used version detect your phone and driver are well installed.
3) if you validated the access on your phone for the current PC. You can invalidate all adb access and wait for new request.
ok, it seems i'm doing something wrong, "adb devices -l" comes up with nothing.
this is not as easy as i thought, giving up here.

/Edit: works now, had to install the samsung usb drivers again.
licenced and happy TC user since 1994 (#11xx)

flo
Junior Member
Junior Member
Posts: 48
Joined: 2007-01-21, 14:57 UTC

Post by *flo » 2017-09-18, 08:20 UTC

flo wrote:Since 8.x version no icons appear in options for this plugin (.apps, .backup, .bugreport,..). With 7.4 i dont't have this problem

anybody else has this problem?
I was reviewing the plugin with resource hacker and i discovered icon resources are missing in the new 8 version.

Could they be included in the new version?

Thanks a lot!

iana
Senior Member
Senior Member
Posts: 342
Joined: 2010-07-27, 22:00 UTC

Post by *iana » 2017-09-18, 10:32 UTC

flo wrote:
flo wrote:Since 8.x version no icons appear in options for this plugin (.apps, .backup, .bugreport,..). With 7.4 i dont't have this problem

anybody else has this problem?
I was reviewing the plugin with resource hacker and i discovered icon resources are missing in the new 8 version.

Could they be included in the new version?

Thanks a lot!
I noticed the author removed the icons when he ported the code to linux as the elf format does not include resources and the author plans to support linux too I doubt the icon will return

mortalis
Junior Member
Junior Member
Posts: 3
Joined: 2016-03-27, 21:49 UTC

Post by *mortalis » 2017-10-17, 07:18 UTC

HI. Is it possible to share the source code of this plugin? Thanks.

User avatar
MVV
Power Member
Power Member
Posts: 8121
Joined: 2008-08-03, 12:51 UTC
Location: Russian Federation

Post by *MVV » 2017-10-20, 19:01 UTC

Hi, can you bring some light onto my problem?

I copy files from ADB to local drive, and most files get incorrect timestamps. When I sync them with ADB folder, I see that local ones has nonzero seconds (and every file has different seconds) while ADB ones have zero seconds. It looks like a bug because I see one timestamp and copy with another one... So it adds another bunch of sync problems because most files looks different due to different timestamps...

Some timestamps from Sync dialog (left files are local ones, right ones on ADB):

Code: Select all

23.08.16	10:50:20	->	23.08.16	10:49:59
05.03.17	14:18:56	->	05.03.17	14:18:00
01.06.16	11:00:56	->	01.06.16	11:00:00
19.10.17	08:09:30	->	19.10.17	08:09:00
03.12.14	12:01:22	->	03.12.14	12:01:00
I'm tested it on version 8.2 (from pluginst.inf, though ADBPlugin.wfx has version 10.4) which was just downloaded from totalcmd.net.

siealex
Senior Member
Senior Member
Posts: 222
Joined: 2009-03-22, 16:36 UTC

Post by *siealex » 2018-02-03, 16:22 UTC

A major bug with file lists.
Windows 10 x64, TC 9.12 x32, ADB plugin 8.0.
LG Nexus 5x, Android 8.1 Oreo.
Files with spaces in their names are displayed incorrectly: only the last word in the name with one space before it.
Image: http://storage5.static.itmages.ru/i/18/0203/h_1517674950_9915118_42e6ec1ee7.jpg
Image: http://storage3.static.itmages.ru/i/18/0203/h_1517674919_2297512_54bc6112e5.png
The bug persists in 8.2 (or is it 8.2?)
We are not so S.M.A.R.T. as we imagine...

User avatar
Tichij
Junior Member
Junior Member
Posts: 21
Joined: 2011-02-22, 12:33 UTC
Location: Lithuania

Post by *Tichij » 2018-02-13, 05:28 UTC

siealex wrote:Files with spaces in their names are displayed incorrectly
I also noticed this and I think I know the reason: rules for forming the list have changed, now a "" symbol is inserted before the spaces.
A short extract from plugin's debug.log before and after upgrade to Android 8.1:
before

Code: Select all

...
2018-02-06 12:46:00 [1004] ADB Write: shell:ls -la "/sdcard/Download/"
...
drwxrwx--x 19 root sdcard_rw     4096 2017-12-05 15:02 .
drwxrwx--x 29 root sdcard_rw     4096 2017-12-05 21:07 ..
drwxrwx--x 23 root sdcard_rw     4096 2017-12-05 07:10 ALL NEW UX
drwxrwx--x  2 root sdcard_rw     4096 2017-12-05 15:03 BackupAndRestore
drwxrwx--x  2 root sdcard_rw     4096 2017-12-05 07:13 MEGA Downloads
-rw-rw----  1 root sdcard_rw       72 2017-11-30 13:47 a.txt
drwxrwx--x  7 root sdcard_rw     4096 2017-12-05 07:11 global_cfg
...
after

Code: Select all

...
2018-02-07 10:45:31 [20E0] ADB Write: shell:ls -la "/sdcard/Download/"
...
drwxrwx--x  4 root sdcard_rw     4096 2017-12-07 08:31 .
drwxrwx--x 29 root sdcard_rw     4096 2017-12-07 09:01 ..
drwxrwx--x 23 root sdcard_rw     4096 2017-12-05 07:10 ALL\ NEW\ UX
drwxrwx--x  2 root sdcard_rw     4096 2017-12-05 15:03 BackupAndRestore
drwxrwx--x  2 root sdcard_rw     4096 2017-12-05 07:13 MEGA\ Downloads
-rw-rw----  1 root sdcard_rw       72 2017-11-30 13:47 a.txt
drwxrwx--x  7 root sdcard_rw     4096 2017-12-05 07:11 global_cfg
...
#49857 Personal licence
Windows 10 Pro 64bit. TC 9.21 32 + 64bit

Post Reply