This forum uses cookies. Click X button to hide this message. What is stored? / Privacy
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Starting in May, forum only via HTTPS - report problems now!

 
Post new topic   Reply to topic    Total Commander Forum Index -> Total Commander (English) Printable version
View previous topic :: View next topic  
Author Message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35745
Location: Switzerland

PostPosted: Thu Apr 26, 2018 4:10 am    Post subject: Starting in May, forum only via HTTPS - report problems now! Reply with quote

Due to the EU data protection regulation DSGVO, which requires the secure transmission of all personal data, our forum will be accessible only via HTTPS, starting in May 2018 (latest on 24.5.).

Please write here in this thread if you have problems reaching the forum via HTTPS.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
petermad
Power Member
Power Member


Joined: 05 Feb 2003
Posts: 7788
Location: Valsted, Denmark

PostPosted: Thu Apr 26, 2018 2:29 pm    Post subject: Reply with quote

There si a problem when navigating the Forum, when I middle-click one of the little orange icons to the left of the topic title for "viewing new posts since last visit" - then the new tab is opened as http even though the original tab was in https. This does not happen if I for example middle-click the title of the topic, only when clicking the icon.
_________________
#524
Danish Total Commander Translator
TC 9.20rc1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit. TC 2.91b3 on Android 6.0

Get Extended Total Commander Menus
Back to top
View user's profile Send private message Send e-mail Visit poster's website
sqa_wizard
Power Member
Power Member


Joined: 06 Feb 2003
Posts: 3351
Location: Germany

PostPosted: Thu Apr 26, 2018 3:08 pm    Post subject: Reply with quote

Well, not really a problem with the forum directly, but:

1. you may change the link at your signature to https Wink
2. the items delivered by a RSS feed are still linked to http even though the source is https
_________________
#5767 Personal license
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35745
Location: Switzerland

PostPosted: Fri Apr 27, 2018 2:41 am    Post subject: Reply with quote

The RSS feed problem should be fixed now, thanks. The problem is that the forum is running behind an NGINX reverse proxy, which then gets the data locally via http from Apache/php. Therefore the php function only sees a http connection, and returns http links.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
petermad
Power Member
Power Member


Joined: 05 Feb 2003
Posts: 7788
Location: Valsted, Denmark

PostPosted: Fri Apr 27, 2018 12:43 pm    Post subject: Reply with quote

Quote:
you may change the link at your signature to https

Just did that -. thanks Smile

Also, the email notifications send out when there is a new posting in a thread shows the links with http:// and not https:// - and that is my most frequent entry to the forum.
_________________
#524
Danish Total Commander Translator
TC 9.20rc1 32+64bit on Win XP 32bit, Win 7, 8.1 & 10 64bit. TC 2.91b3 on Android 6.0

Get Extended Total Commander Menus
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35745
Location: Switzerland

PostPosted: Mon May 07, 2018 4:43 am    Post subject: Reply with quote

All requests for php pages are now redirected to https.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Hacker
Moderator
Moderator


Joined: 06 Feb 2003
Posts: 10887
Location: Bratislava, Slovakia

PostPosted: Mon May 07, 2018 7:31 am    Post subject: Reply with quote

My old and unmaintained RSS reader stopped updating the RSS feed today at around 10:30 CEST (+- one hour), citing "Error connecting with SSL.". Unfortunately I am unable to get more details. I am using the following URL:
https://www.ghisler.ch/board/rss.php

Unfortunately I will have to assume that the problem is on my end and since the RSS reader is unmaintained I will have to start using another one. Any suggestions for an RSS reader that can group posts belonging to the same thread?

Roman
_________________
Mal angenommen, du drückst Strg+F, wählst die FTP-Verbindung (mit gespeichertem Passwort), klickst aber nicht auf Verbinden, sondern fällst tot um.
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35745
Location: Switzerland

PostPosted: Mon May 07, 2018 2:43 pm    Post subject: Reply with quote

It looks like your rss reader isn't capable of https, or cannot handle our certificate. have therefore excluded /board/rss.php from the redirect rule, so you should be able to connect to the http url instead:
http://www.ghisler.ch/board/rss.php
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Hacker
Moderator
Moderator


Joined: 06 Feb 2003
Posts: 10887
Location: Bratislava, Slovakia

PostPosted: Mon May 07, 2018 4:18 pm    Post subject: Reply with quote

Christian,
Cool, it works both via https (testing other RSS readers) and http (using my old RSS reader) now, thanks!

Roman
_________________
Mal angenommen, du drückst Strg+F, wählst die FTP-Verbindung (mit gespeichertem Passwort), klickst aber nicht auf Verbinden, sondern fällst tot um.
Back to top
View user's profile Send private message Send e-mail
DrShark
Power Member
Power Member


Joined: 03 Nov 2006
Posts: 1111
Location: Kyiv, 68/262

PostPosted: Mon May 14, 2018 2:49 am    Post subject: Reply with quote

The links:
http://ghisler.ch/board/
http://www.ghisler.ch/board/
are is still not redirected to https, while they have a "Log in" part with "Username" and the "Password" fields at the bottom of the page.

If protecting the login/password forms is the only reason of moving the forum to https, maybe it's possible to offer the forum over http without "Username" and the "Password" fields (they may be replaced by the https [www.]ghisler.ch/board/login.php link)?
_________________
Android 4.3.1 no root, kernel 08.09.2016; Vista Home Premium SP2 rus 32 bit
TC #149847 Personal licence

Cuz we're all in this together, We're here to make it right
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35745
Location: Switzerland

PostPosted: Mon May 14, 2018 3:31 am    Post subject: Reply with quote

Fixed, thanks! I was checking just for the .php extension.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
VSB
Member
Member


Joined: 12 Dec 2006
Posts: 130
Location: Russia

PostPosted: Mon May 14, 2018 6:13 pm    Post subject: Reply with quote

Currently, any posting causes

Could not connect to smtp host : 111 : Connection refused

DEBUG MODE

Line : 114
File : smtp.php
Back to top
View user's profile Send private message
AdityaInfotech
New Member
New Member


Joined: 15 May 2018
Posts: 1

PostPosted: Tue May 15, 2018 2:29 am    Post subject: Re: Starting in May, forum only via HTTPS - report problems Reply with quote

ghisler(Author) wrote:
Due to the EU data protection regulation DSGVO, which requires the secure transmission of all personal data, our forum will be accessible only via HTTPS, starting in May 2018 (latest on 24.5.).

Please write here in this thread if you have problems reaching the forum via HTTPS.


No. There is no problem while reaching this forum.

Moderation:
Advertisement link removed from profile / signature.

Hacker (Moderator)
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35745
Location: Switzerland

PostPosted: Tue May 15, 2018 2:32 am    Post subject: Reply with quote

2VSB
Thanks, the smtp server didn't start automatically after rebooting the server.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> Total Commander (English) All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung | Politique de Confidentialité

Using phpBB © phpBB Group