Search doesn't search in content LibreOffice files

The behaviour described in the bug report is either by design, or would be far too complex/time-consuming to be changed

Moderators: sheep, Hacker, Stefan2, white

Post Reply
willygeerts
Junior Member
Junior Member
Posts: 4
Joined: 2010-11-16, 22:33 UTC
Location: Belgium - Antwerpen
Contact:

Search doesn't search in content LibreOffice files

Post by *willygeerts »

TC : 9.10
LibreOffice : 5.4.2.2 (x64)
W10 : Windows 10 Pro (version 1709)

Trying to find files by keywords in content of LibreOffice files (ods/odt/...).
The files are valid since windows indexes the contents.
The option 'Office xml' is ticked when I try to search contents.

In previous versions TC this did work, I use it every day in my job.
User avatar
Horst.Epp
Power Member
Power Member
Posts: 3884
Joined: 2003-02-06, 17:36 UTC
Location: Germany

Post by *Horst.Epp »

Not confirmed
Tested with several odt files and no problem to find the words searched for.
Of course with having the Office XML box selected in find text.
Windows 10 Home x64 Version 20H2 (OS Build 19042.608)
TC 9.51 x64 / x86, Everything 1.4.1.996 (x64)
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 39985
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Post by *ghisler(Author) »

What exactly are you looking for? If you are looking for accents or umlauts, they may not be found, because they can be encoded in different ways, e.g. ä = ä. TC only looks for ä encoded as UTF-8 in the xml files.

You can try to open the ods/odt file with Ctrl+PageDown as a ZIP, then look at the individual xml files to find out how the search word is encoded.
Author of Total Commander
http://www.ghisler.com
Post Reply