Webdav problem with öäü

Discuss and announce Total Commander plugins, addons and other useful tools here, both their usage and their development.

Moderators: sheep, Hacker, Stefan2, white

Post Reply
pingu
Junior Member
Junior Member
Posts: 4
Joined: 2020-09-10, 09:49 UTC

Webdav problem with öäü

Post by *pingu »

I use the webdav plugin with ILIAS. A few weeks ago ILIAS was updated and now folders with umlauts no longer work. It still works with "Map network drive" in Windows 10.
Does anyone have a hint?


******Received headers
HTTP/1.1 302 Found
Date: Thu, 10 Sep 2020 10:11:10 GMT
Server: Apache
Set-Cookie: ilClientId=hslu; path=/; HttpOnly
Location: error.php
Strict-Transport-Security: max-age=31536000
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Content-Length: 0
Keep-Alive: timeout=5, max=97
Connection: Keep-Alive
Content-Type: text/html; charset=UTF-8
Error: 302 Found
HTTP error: Error 12168, FormatMessage error 15105
PROPFIND /ilias/webdav.php/hslu/ref_1234567/%c3%9cbungen/ HTTP/1.1
Depth: 1
Content-type: text/xml; charset="utf-8"
User-Agent: ezdavplugin/3.0 TotalCommander/9.5 (Windows/8; en_EN)
Host: elearning.hslu.ch
Content-Length: 0
Connection: Keep-Alive
Cache-Control: no-cache
Cookie: ilClientId=hslu; PHPSESSID=d5f3ee51xxxx....
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40066
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Webdav problem with öäü

Post by *ghisler(Author) »

It could be a problem with Unicode UTF-8. %c3%9c is the German "Ü" coded as UTF-8. Try the changing various Unicode options in the connection settings.
Author of Total Commander
http://www.ghisler.com
pingu
Junior Member
Junior Member
Posts: 4
Joined: 2020-09-10, 09:49 UTC

Re: Webdav problem with öäü

Post by *pingu »

I tried the following setting, unfortunately it doesn't work either:
"Akzentzeichen in URLs als UTF-8 Unicode senden"

(checkbox now unchecked, in the first post checked)
Get dir: /ilias/webdav.php/hslu/ref_4529632\Ãœbungen
HTTP error: Error 12168, FormatMessage error 15105
PROPFIND /ilias/webdav.php/hslu/ref_4529632/%c3%9cbungen/ HTTP/1.1
Depth: 1
Content-type: text/xml; charset="utf-8"
User-Agent: ezdavplugin/3.0 TotalCommander/9.5 (Windows/8; en_EN)
Host: elearning.hslu.ch
Content-Length: 0
Connection: Keep-Alive
Cache-Control: no-cache
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40066
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Webdav problem with öäü

Post by *ghisler(Author) »

I have searched for error 12168, and it seems to mean the following:
>>Error 12168 occurs when there is a request which cannot be directed automatically. It could be a redirect from http to https. Try checking the option "Secure connection (via SSL)" in the connection settings. ghisler(Author) wrote: "Moved Permantently" means that the entered URL is wrong.<<

Apparently the server tries to redirect you somewhere. Can you see anything in the log?
1. Enable detailed logging in the connection settings
2. Enable FTP logging in Total Commander, it also logs plugins: Confguration - Options - FTP.
Author of Total Commander
http://www.ghisler.com
pingu
Junior Member
Junior Member
Posts: 4
Joined: 2020-09-10, 09:49 UTC

Re: Webdav problem with öäü

Post by *pingu »

>Try checking the option "Secure connection (via SSL)
I tried both, with and without Secure connection. I created two logfiles with the following configuration:
Image: http://www.jost.li/tc/Config.PNG

Connect => Doubleclick on folder Übungen => Disconnect (with error):
http://www.jost.li/tc/tcftp_Access_Übungen_Folder.log

Connect => Doubleclick on folder Uebungen => Disconnect (without error):
http://www.jost.li/tc/tcftp_Access_Uebungen_Folder.log

I can't see anything new.
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40066
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Webdav problem with öäü

Post by *ghisler(Author) »

According to the log, the server redirects you to the _same_ address each time you try to access the page with accents.
Could you retry the test with appended slash "/" in the URL? You can set this option in the connection properties (last option).
Author of Total Commander
http://www.ghisler.com
pingu
Junior Member
Junior Member
Posts: 4
Joined: 2020-09-10, 09:49 UTC

Re: Webdav problem with öäü

Post by *pingu »

Unfortunately, it doesn't matter, the error is the same:

With "/"
Create dir: /ilias/webdav.php/hslu/ref_4529947\testü
HTTP error: Error 12168, FormatMessage error 15105
MKCOL /ilias/webdav.php/hslu/ref_4529947/test%c3%bc/ HTTP/1.1
User-Agent: ezdavplugin/3.0 TotalCommander/9.5 (Windows/8; en_EN)
Host: elearning.hslu.ch
Content-Length: 0
Connection: Keep-Alive
Cache-Control: no-cache
Cookie: ilClientId=hslu; PHPSESSID=87033cdb2fe1afaec98beac019f6443a
******Received headers
HTTP/1.1 302 Found
Date: Wed, 23 Sep 2020 04:52:31 GMT
Server: Apache
Set-Cookie: ilClientId=hslu; path=/; HttpOnly
Location: error.php
Strict-Transport-Security: max-age=31536000
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Content-Length: 0
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html; charset=UTF-8
Error: 302 Found

And without "/"
Create dir: /ilias/webdav.php/hslu/ref_4529947\testü
HTTP error: Error 12168, FormatMessage error 15105
MKCOL /ilias/webdav.php/hslu/ref_4529947/test%c3%bc HTTP/1.1
User-Agent: ezdavplugin/3.0 TotalCommander/9.5 (Windows/8; en_EN)
Host: elearning.hslu.ch
Content-Length: 0
Connection: Keep-Alive
Cache-Control: no-cache
Cookie: ilClientId=hslu; PHPSESSID=a7650f2aa88451c8127cf9248e0a79f2
******Received headers
HTTP/1.1 302 Found
Date: Wed, 23 Sep 2020 04:53:57 GMT
Server: Apache
Set-Cookie: ilClientId=hslu; path=/; HttpOnly
Location: error.php
Strict-Transport-Security: max-age=31536000
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Content-Length: 0
Keep-Alive: timeout=5, max=99
Connection: Keep-Alive
Content-Type: text/html; charset=UTF-8
Error: 302 Found
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40066
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Webdav problem with öäü

Post by *ghisler(Author) »

HTTP/1.1 302 Found
means that the Web server wants to redirect you somewhere else.
Author of Total Commander
http://www.ghisler.com
User avatar
elgonzo
Power Member
Power Member
Posts: 639
Joined: 2013-09-04, 14:07 UTC

Re: Webdav problem with öäü

Post by *elgonzo »

ghisler(Author) wrote:
2020-09-25, 13:34 UTC
HTTP/1.1 302 Found
means that the Web server wants to redirect you somewhere else.
That "somewhere else" is an error page/document:
pingu wrote:
2020-09-23, 04:56 UTC
Location: error.php
It would perhaps be good to know what that error document is saying...

Is there a way to let the plug-in log the response (especially the body) for this redirect?
Windows 7 Pro x64 SP1
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40066
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: Webdav problem with öäü

Post by *ghisler(Author) »

You need to contact me by e-mail for a private test version.
Author of Total Commander
http://www.ghisler.com
Post Reply