SFTP plugin - unsupported ETM HMACs

Support for Android version of Total Commander

Moderators: sheep, Hacker, Stefan2, white

Post Reply
Tsunulukai
Junior Member
Junior Member
Posts: 60
Joined: 2003-02-07, 23:44 UTC

SFTP plugin - unsupported ETM HMACs

Post by *Tsunulukai »

Hello,

I'm trying to connect to a server that only offers etm (encrypt then mac) HMACs, but the plugin fails to reach a settlement:

Code: Select all

Connect call failed
Transport exception: Unable to reach a settlement: [hmac-sha1, <more hmacs> ] and [hmac-sha2-512-etm@openssh.com,hmac-sha2-256-etm@openssh.com]
Their use being recommanded in the sshd_config manpage itself, would you consider supporting them ?
The algorithms that contain "-etm" calculate the MAC after encryption (encrypt-then-mac). These are considered safer and their use recommended.
Here's the list of ETM HMAC from the same man page:

Code: Select all

hmac-md5-etm@openssh.com
hmac-md5-96-etm@openssh.com
hmac-sha1-etm@openssh.com
hmac-sha1-96-etm@openssh.com
hmac-sha2-256-etm@openssh.com
hmac-sha2-512-etm@openssh.com
umac-64-etm@openssh.com
umac-128-etm@openssh.com
I'd be happy to beta-test this for you.
Best regards,
User avatar
ghisler(Author)
Site Admin
Site Admin
Posts: 40072
Joined: 2003-02-04, 09:46 UTC
Location: Switzerland
Contact:

Re: SFTP plugin - unsupported ETM HMACs

Post by *ghisler(Author) »

According to the homepage of the library I use, the etm hmac versions should be supported:
https://github.com/hierynomus/sshj

Could you try with the latest beta? I cannot say when this was added to sshj, but the beta uses the latest version of the library:
https://play.google.com/apps/testing/com.ghisler.tcplugins.SFTP
Author of Total Commander
http://www.ghisler.com
Tsunulukai
Junior Member
Junior Member
Posts: 60
Joined: 2003-02-07, 23:44 UTC

Re: SFTP plugin - unsupported ETM HMACs

Post by *Tsunulukai »

Works perfectly with the current beta !
Thanks :)
Post Reply