This forum uses cookies. Click X button to hide this message. What is stored? / Privacy
Total Commander Forum Index Total Commander
Forum - Public Discussion and Support
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Mounted drive entry is not removed

 
Post new topic   Reply to topic    Total Commander Forum Index -> TC Fixed bugs Printable version
View previous topic :: View next topic  
Author Message
Sektor
Member
Member


Joined: 04 Apr 2007
Posts: 107
Location: Russia

PostPosted: Sat Jun 02, 2018 12:34 pm    Post subject: Mounted drive entry is not removed Reply with quote

I have mounted some ISO file. When I am in \\This PC\, I see drive entry. But when I unmount drive in Total Commander (right-click -> Eject), then the entry doesn't go away. When TC looses focus and gains it again, then the entry goes away. I have attached my Refresh settings.

This PC. Image: https://i.imgur.com/8WfvZj5.png
Refresh. Image: https://i.imgur.com/MNbSmAx.png
_________________
#299429
There is no knowledge that is not power


Last edited by Sektor on Wed Jun 13, 2018 1:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35752
Location: Switzerland

PostPosted: Sun Jun 03, 2018 4:29 am    Post subject: Reply with quote

TC does not support auto refresh in virtual folders. Switching away from TC and back causes a refresh. Or you can use F2 or Ctrl+R.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Sektor
Member
Member


Joined: 04 Apr 2007
Posts: 107
Location: Russia

PostPosted: Sun Jun 03, 2018 4:33 am    Post subject: Reply with quote

@ghisler
OK.
_________________
#299429
There is no knowledge that is not power
Back to top
View user's profile Send private message
Dalai
Power Member
Power Member


Joined: 28 Jan 2005
Posts: 6049
Location: Meiningen (Südthüringen)

PostPosted: Sun Jun 03, 2018 7:58 am    Post subject: Reply with quote

2ghisler(Author)
But it works when a drive is added (by mounting an image or connecting an external drive).

Regards
Dalai
_________________
#101164 Personal licence
Athlon X4 880K, 16 GiB RAM, Gigabyte F2A88X-D3HP, Win7 x64

Plugins: Services2, Startups
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35752
Location: Switzerland

PostPosted: Tue Jun 05, 2018 2:23 am    Post subject: Reply with quote

Yes, this is done manually when WM_DEVICECHANGE is received with DBT_DEVICEARRIVAL. I will add refresh also when device is removed.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35752
Location: Switzerland

PostPosted: Wed Jun 06, 2018 10:43 am    Post subject: Reply with quote

This should be working now in beta 6, please test it!
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Sektor
Member
Member


Joined: 04 Apr 2007
Posts: 107
Location: Russia

PostPosted: Wed Jun 06, 2018 10:50 am    Post subject: Reply with quote

@ghisler
Alas, doesn't work... Sad
_________________
#299429
There is no knowledge that is not power
Back to top
View user's profile Send private message
Dalai
Power Member
Power Member


Joined: 28 Jan 2005
Posts: 6049
Location: Meiningen (Südthüringen)

PostPosted: Wed Jun 06, 2018 3:03 pm    Post subject: Reply with quote

It's better than before.

Test case where TC refreshes properly now:
  1. Have \\Computer in the left panel
  2. Mount some ISO in the right panel
  3. Right-click on the new drive in the left panel and eject it

Test case where TC still doesn't refresh
  1. Have \\Computer in the left panel
  2. Mount some ISO in the right panel
  3. Switch to the new drive in the right panel
  4. Right-click on the path bar of the right panel and eject the drive

Regards
Dalai
_________________
#101164 Personal licence
Athlon X4 880K, 16 GiB RAM, Gigabyte F2A88X-D3HP, Win7 x64

Plugins: Services2, Startups
Back to top
View user's profile Send private message Send e-mail
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35752
Location: Switzerland

PostPosted: Thu Jun 07, 2018 3:12 am    Post subject: Reply with quote

Thanks, I could reproduce test case 2.
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ghisler(Author)
Site Admin
Site Admin


Joined: 04 Feb 2003
Posts: 35752
Location: Switzerland

PostPosted: Wed Jun 13, 2018 12:00 pm    Post subject: Reply with quote

This should be fixed in TC 9.20 release candidate 1, please test it!
_________________
Author of Total Commander
http://www.ghisler.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Sektor
Member
Member


Joined: 04 Apr 2007
Posts: 107
Location: Russia

PostPosted: Wed Jun 13, 2018 12:29 pm    Post subject: Reply with quote

@ghisler
In TC 9.20 RC1 now works OK! Smile
_________________
#299429
There is no knowledge that is not power
Back to top
View user's profile Send private message
Dalai
Power Member
Power Member


Joined: 28 Jan 2005
Posts: 6049
Location: Meiningen (Südthüringen)

PostPosted: Wed Jun 13, 2018 12:54 pm    Post subject: Reply with quote

I confirm the fix, too.

Regards
Dalai
_________________
#101164 Personal licence
Athlon X4 880K, 16 GiB RAM, Gigabyte F2A88X-D3HP, Win7 x64

Plugins: Services2, Startups
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Total Commander Forum Index -> TC Fixed bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Imprint/Impressum: This site is maintained by Ghisler Software GmbH
Privacy Policy | Datenschutzerklärung | Politique de Confidentialité

Using phpBB © phpBB Group